ImageDataBunch is not defined

I am trying to install fastai in my windows 10.

My laptop has no GPU, I am using pip in cmd to install fastai.

In pip page(, they mentioned to install pytroch before installing fastai.

I followed that step,

For pytorch(

pip install torch==1.6.0+cpu torchvision==0.7.0+cpu -f

Then, For fastai-

pip install fastai

These python packages are installed successfully.

from import *

This statement is imported successfully,

But when I use the ImageDataBunch function,

data = ImageDataBunch.from_folder(path, train=".", valid_pct=0.2, size=512, bs=4, seed=24)

It shows error, NameError: name ‘ImageDataBunch’ is not defined

I do not know what is happening, Could you please help me to solve this error, thanks

1 Like

The same issue as here Getting load_learner not defined

fastai is now in version 2
in version 2 there is no ImageDataBunch anymore, switch back to version 1 or migrate to version 2

1 Like

I am just copying from there notebook only. Why they have written it?

Yes, @Kornel, that is what I done finally, moved to version 1, working now, thanks

me too getting the same error. I have changed my fastai version2 to v1 but still getting the error. Can anyone please help me out!

Hello @Kornel. But the book still has the command. I was following the book when this error also popped up on my personal laptop.

Everything worked fine on colab and gradient though.

Welcome @vipulsaklani.
I think there is a problem somewhere. I will try and contact them on the discord channel. If I get an answer I will relay it back here.