Howto: installation on Windows

Hi again,
I am trying to install Fastai for cpu users. I am running Windows 10 on Surface Laptop, and have two Anacondas (one for Python 2.7 and another for Python 3.6) i am not very skilled with bash as you could see.
I have some error that i have not seen so far on the Forum, so i do not know if it is appropriate to open a topic or not. Anyway, after running pytest tests I have seen the error ModuleNotFoundError for torchtext.
While running pip install torchtext I got a message that torchtext is successfully installed with a bunch of messages of uninstalled packages which I am not sure they are relevant:
Then I ran pytest tests and got the following errors:

Then I decided to install the version of libraries mentioned in previous message (PyHamcrest, hypothesis…). When I tried to install thinc due to “spacy 2.0.11 has requirement thinc<6.11.0,>=6.10.1, but you’ll have thinc 6.11.2 which is incompatible”, I have gotten the message: “failed building wheel for thinc” and for cytoolz too, due to
error: Microsoft Visual C++ 14.0 is required. Get it with “Microsoft Visual C++ Build Tools”:
The link is offline and then I have tried implicit trick from github error: Microsoft Visual C++ 14.0 is required and installed at the end Microsoft Visual Studio 2017.
At the end, yes there is, I run pytest tests and got the Assertion error ierror: Microsoft Visual C++ 14.0 is requiredn
So question is whether you know how I could get rid of the last AssertionError and was it necessairy to install all libraries (PyHamcrest, thinc and so on)?
Please if you happened to know what to do whom I could ask for a help let me know.
Sorry for long story, I am very confused and beginner with installing things so I thought every detail is important.
Any suggestion about way of posting is welcome.

Thanks a lot for your time and hope we will learn something out of this adventure.

When I try to create the bellow

mklink /d fastai …\fastai

I ran into problems following these steps list out my @jeremy. I am using Windows 10 with Cuda toolkit 9.0 and 1 gtx 1080 as my gpu. The problem is mainly with installing Shapely and Fiona packages in Windows.

In my computer they could not be installed following the above steps with “conda env update” command. So I had manually download the “.whl” files for these packages and install with pip install, while activating the fastai conda env and then again deactivating the environment and do conda env update to properly install fastai.

In case someone is facing the same problem, just download these two packages from below, and pip install it manually activating the fastai environment.

I got stuck with this in step 5 of the instructions. Please help!

I followed the instructions and got stuck on the compile problem of fiona.
I simply added these lines at the beginning of environment.yml and the installation succesfully finished:

  • gdal
  • fiona
  • scipy>=1.0.0

I’m absolutely not an expert about this stuff and I didn’t understand exactly how dependencies work, but if you add these packages to the environment, maybe it will solve for other users without any manual operation or fiona rebuild.

Now I have another problem because I don’t have the data/dogscats/ folder and I don’t know how to launch the examples :slight_smile:


I was able to get this running after running conda install graphviz

The other option seems like to setup an environment variable but I haven’t tried this.

Some SO posts I checked out to fix this:

Thank you Todd! Your comments were extremely helpful!

For anyone else that didn’t realize this, make sure you have activated the fastai environment prior to setting the Environment variables for this to work.

conda env update

I am actually looking for a dedicated IP for Windows. Where can I get this? I have shortlisted Ivacy, but not sure whether to go for it or not. I know my comment is not directly relevant to your query, but any assistance regarding this would help me big time.

Were you able to resolve this? I am getting the same error.

not yet

Adding dependency

  • conda-forge::fiona>=1.7.13

worked for me like a charm. Thanks!

Adding the “- conda-forge::fiona>=1.7.13” to environment.yml (insert into line 39) works for me on Windows 10.
As suggested by @neeravbm


Thanks! This worked for me as well.

Hi jeremy the following error keeps showing up again and again:

Command “python egg_info” failed with error code 1 in C:\Users\Arunabh\AppData\Local\Temp\pip-install-u051lea7\pyproj\

I tried everything mentioned in the forums even what @toddprater and @Hisham have mentioned about fiona installation.

Still the above error shows up. Please assist me

Not sure if your error is exactly the same as the one I encountered when installing pyproj.

I solve the problem by installing Build Tools for Visual Studio 2017

Were you able to solve the problem? I’m getting the same error.

Worked for me thanks!

I’m facing the same issue. But when I click on the link it does take me to fastai install directory. Is there any fix for that?