How to setup virtual machine on Azure for running course lessons?

I know this question may seem repeated or asked several times.

But What all do I need to install on the virtual machine I create on azure. Which virtual machine to choose?
Is azure having faster instances then aws , like in paperspace?

Also I want to try running some lessons on my PC ( GTX 1050 4GB ). Should I use Linux Sub System for windows or partition my hard drive? how can I setup my Linux after that ( I have seen intro:workshop video , so what else apart from that)

P.S - I want to use azure as I am Microsoft Student partner , and I get Visual Studio Subscription ( with 150 $ credits every month). Just I want to learn for my future use.

1 Like

Hi @vrajjshah

How did you get in with running Azure - I also have access to the VS subscription and so am wondering if its a worthwhile resource for our Pytorch learning once the AWS credit runs out.

Hi @Chris_Palmer, I am able to get Azure running with our fast ai using the Visual Studio Subscription. If you need any info on the same, let me know.

Hey @manikanta_s could you share the steps here ? So even I can get to know how to get azure running(for fast ai) with my visual studio enterprise subscription? Even others can benefits who have the same question

Sure, will put up a small post and share it.

1 Like

Just saw this @manikanta_s - I sure would like the information - please send it along :wink: or post for general consumption!

I have created the below post with necessary details.

I followed the Azure GPU setup process and i am stuck here in the red colored portion in below image.

my question SSH to ubuntu VM means connect to the ubuntu VM hosted in Azure cloud through linux bash(here cygin has some issue so using github bash) like below

So while connection it is asking password .So what is password i should give ?
Is it asking key in the “id_rsa”?
any help will be appreciated.

I gave my password to azure account and connected .After that i need to install the script in the linux/ubuntu vm .So how do that?I am new to linux.(DO i have to connect through remote desktop to the linux VM and then install the script or through terminal (here for me GIT bash)?

Hello Chris,
Were you able to get Azure to run? I got stuck when setting up the Deep Learning DC VM.

Hi Jefferson

No, I haven’t even had time to try it yet, but I do intend to try soon. I’ll let you know if I make any progress…

Hi, I managed to create a VM (Deep Learning template).

So now I start a jupyter server using jupyter notebook --no-browser which gives me a link. I click on that link but the browser (Chrome) says The site can't be reached. I tried replacing localhost with the IP address but the output is still the same.

Any help?

Finally got around to trying this - but unfortunately all options were grayed out and were very expensive anyway - even the NC6 was over $800 a month. I made a couple of requests for access but so far nothing has been granted. Might be a waste of time anyway with those prices…

You have to send email to MS office for enabling them the NC6 machines.Although it is is showing the 800$ …u will not that much .If u have leaready have MSDN account then it comes 150$ of monthly free credit and no credit card nor bank account details required.So dont worry just send amail to MS team.I am using azure through MSDN Visual Studio Enterprise account.

follow the above link

Thanks Susant,

I did send a message, but they haven’t granted it to me! Not sure why - I will try again.

But the other issue I could see is that these use Python 3.5 and CUDA 8, whereas the requirements is 3.6 and CUDA 9. Are you able to upgrade the VM?

They will reply …it will take may 2-3 days .for me it took 3 days.

I am here in python 2.7 and heard that 2018 v1 is using python 3.6 but when i took the batch script for azure it is automatically took python 2.7 and i want to update also python 3.6
I am stuck with other issue like “import utils; reload(utils)
from utils import plots” although i ama bale to run the lession.ipnb and able to go upto some level.\

Thanks Susant

Did you build the environment using conda env?

No i am using Git Bash for terminal

What I meant was, after doing a git clone to get the library, did you then execute a conda env create -f environment.yml while in the newly created fastai directory, so that you could use the environment.yml file supplied by fastai?