Having challenges to upload large file to Paperspace


(Hugues) #1

Hi everyone,

really struggling to upload a 5 gig zipped file to my console on Paperspace.

I’m uploading first to my Google drive and following the instructions to bypass the Virus scan warning. I know my google link works because when i call it with Chrome i can download the file immediately without any messages.

But when i call the same link with wget, i get the following response in my console:
[3] 2337
[4] 2338
[1] Exit 127 https://drive.google.com/uc?export=download
[2] Done confirm=TfY6
https://drive.google.com/uc?export=download
Resolving drive.google.com (drive.google.com)… 216.58.201.110, 2a00:1450:4014:801::200e
Connecting to drive.google.com (drive.google.com)|216.58.201.110|:443… connected.
HTTP request sent, awaiting response… 400 Bad Request
2018-05-24 12:40:44 ERROR 400: Bad Request.

Any help appreciated. It works with Dropbox but i’m limited to 2gig and don’t feel like subscribing to get more space.

I tried to upload directly from my laptop using a local terminal session or the jupyter notebook interface but it is sooooooo slow, 300 kb/s, can’t work this way. I asked Paperspace tech support, they told me their servers are quite loaded these days. My upload through Dropbox was quite fast.


(Reijer) #2

I have exactly this problem. I cannot get the database from this website: https://picnic.devpost.com


(Reijer) #3

This solved it for me: https://stackoverflow.com/questions/48133080/how-to-download-a-google-drive-url-via-curl-or-wget/48133859#48133859