Google Colab TIMEOUT error, previously worked

I’m using Google Colab notebooks.
I noticed that today I’m getting a TIMEOUT error when I run the first cell of the notebook.

It appears to be during the fastbook.setup_book() command.

  1. When I run the 1st cell, I get a Pandas version warning (that seems unconnected) and the link to google drive approval screen, which I follow and ‘Allow’
  2. I copy the key/code (from google) back into the input box, hit return/enter.
  3. The Colab cell seems to hang for a while, running the code then fails with a TIMEOUT.

I’ve attached an image of the error.

Is this a temprary Google issue? or has something changed?

Previously this notebook worked (earlier in the week)



I am getting the same TIMEOUT issue when trying to mount the drive.

@gkumarg For the time being try to manually select the token and then paste. Don’t use the copy button and see if that works.

Actually just tried this and it worked


Yes, that seems to work!
Great work! Thanks @amritv

1 Like

@amritv You just saved a lot of confused moments!! Thank you!!! :pray:

1 Like

Yes exact same problem here