Github actions failing: Notebooks and library not in sync

Firstly, thanks for creating and maintaining such a great tool!

I am working on this repository and cannot get the github actions to work despite best efforts.

I have the precommit hooks for nbdev clean and export enabled and I also run the nbdev_prepare command before committing.
There are no errors locally but CI github action consistently fails with:

+ [[ -n  M jaxDiversity/ ]]
Error: Notebooks and library are not in sync.  Please run nbdev_export.
+ echo '::error::Notebooks and library are not in sync.  Please run nbdev_export.'

And the deploy action fails with:

Exception: Error in notebook: Loops in cell 6 :
from jaxDiversity.dataloading import NumpyLoader, DummyDataset
from jaxDiversity.utilclasses import InnerConfig, OuterConfig, InnerResults, OuterResults
from jaxDiversity.mlp import mlp_afunc, MultiActMLP, init_linear_weight, xavier_normal_init, save
from jaxDiversity.baseline import compute_loss as compute_loss_baseline
from jaxDiversity.hnn import compute_loss as compute_loss_hnn

Error: Process completed with exit code 1.

The error should be replicable by cloning and running github actions on

Thanks in advance for any advice to fix this issue!

Fixed it, my gitignore had a bug preventing one of the notebooks from commiting

hi, has anyone solved this issue? I tried everything but nothing seems to work. I’m basically running a tutorial step by step from the nbdev documentation.