Folding@Home; Use your Deep learning machines to understand COVID-19

Nvidia put out a post asking gamers for support with COVID-19. It turns out with a little bit of tweaking you can alter your deep learning machine to support this. I wrote a quick post to make my hour-long journey into a 10 minute one for you.

Some caveats.

  • The entire system is volatile. I have waited hours for my GPUs to spin up and have to reboot them often.
  • I suspect (but am not sure) there are lots of hobbyists who are doing work with CPUs or are stopping before a Work Unit (WU) is complete. This exacerbates the problem of larger machines are idle.
  • The data is likely going to be in the long run, not a short fix. If you look at papers that folding@home has helped with in the past, they do not look like crazy breakthroughs.
  • I have no clue how to interpret the data or where it is best shared

Bottom line: This seems like a very low-effort, low immediate benefit, and possible long term win situation.

4 Likes

I would love to offer my idle GPU to this effort. But with vanilla Ubuntu 16.04 and a monitor, installation of fahclient_7.5.1_amd64.deb barfs with this uninformative error:

apt transaction returned result exit-failed

I know you are not responsible for folding@home’s error messaging, but any ideas?

Thanks!

Try walking through their manual.
https://foldingathome.org/support/faq/installation-guides/linux/manual-installation-advanced/

It uses a lower version, but I am betting it will work. If not, post the command and error code and we will try again.

Thanks for helping. I’m lost in Linux whenever something goes wrong.

(fastai3) malcolm@PC-GPU:~/Downloads$ sudo dpkg -i --force-depends fahclient_7.5.1_amd64.deb
Selecting previously unselected package fahclient.
(Reading database … 303128 files and directories currently installed.)
Preparing to unpack fahclient_7.5.1_amd64.deb …
Adding system user fahclient…done
Unpacking fahclient (7.5.1) …
Setting up fahclient (7.5.1) …
update-rc.d: error: no runlevel symlinks to modify, aborting!
dpkg: error processing package fahclient (–install):
subprocess installed post-installation script returned error exit status 1
Processing triggers for systemd (229-4ubuntu21.27) …
Processing triggers for ureadahead (0.100.0-19.1) …
Processing triggers for desktop-file-utils (0.22-1ubuntu5.2) …
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20180209-0ubuntu1) …
Rebuilding /usr/share/applications/bamf-2.index…
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) …
Processing triggers for mime-support (3.59ubuntu1) …
Errors were encountered while processing:
fahclient
(fastai3) malcolm@PC-GPU:~/Downloads$

Here’s a dumb question. Why does the folding@home website list only “amd” in the Ubuntu installer section? Isn’t amd the name of a processor company? My processor is “Intel® Core™ i5-6500 CPU @ 3.20GHz × 4”.

Ah, the fun of playing in Linux. Don’t worry; it gets easier the more you struggle. The trick is to ask for help sooner rather than later.

amd-64 means 64-bit cpu, it will work on both Intel and AMD processors. My processor is an Intel® Core™ i5-4690K CPU @ 3.50GHz and running it fine.

I installed fahclient_7.4.4_amd64.deb instead of 7.5.1. Do you get the same errors installing that?

I completely uninstalled fahclient_7.5.1 using Synaptic. But get the same error with

sudo dpkg -i --force-depends fahclient_7.4.4_amd64.deb

Setting up fahclient (7.4.4) …
update-rc.d: error: no runlevel symlinks to modify, aborting!
dpkg: error processing package fahclient (–install):
subprocess installed post-installation script returned error exit status 1

Thanks for trying!

this issue on the FAH repo indicates a possible workaround:

sudo update-rc.d FAHClient defaults
sudo dpkg --configure -a

Hello @mindtrinket and @huitseeker,

The linked bug report does indeed describe the issue. The installer fails if you select the checkbox to not have the client automatically start, a bug that has been reported repeatedly since 2017. WTF!

I did manage to install client and control directly from the .deb, simply by reversing the checkbox. But now the client fails to pick up my GPU automatically. When attempting to add a GPU slot manually, the configuration tab helpfully reports…

On client “local” 127.0.0.1:36330: No available GPUs

I truly appreciate the help from both of you, but I’m giving up. I have better things to do than to debug someone else’s defective software.