Fastpages with custom domain

Hi !
I cloned fastpages as a project page. (
This is working fine.
Now when I want to direct custom domain ( to this page I am getting formatting issues.
This issue (formatting) looked exactly same like when I cloned fastpages to userpage instead of project page.
I did exactly how it need to be done in godaddy DNS MANAGEMENT.

Other things I made

  1. Creating CNAME file with custom domain
  2. Mentioning custom domain in project page settings
  3. In settings>Github Pages> source tried both gh-pages branch and master branch.

Still no luck.

Can someone direct me if there is something I did wrong.
Thanks a million.

Can you try following these instructions carefully

1 Like

This is working perfectly now.

Editing _config.yml file
url to custom domain
and commenting base url worked.
Thank you.

Also I am launching the jekyll server locally. I can see only markdown posts but not jupyter notebook posts. Did I miss something in setting up this locally?

Thank you.

@rakendd I highly recommend going through the README carefully. A screenshot:

I think you will find what you are looking for there

1 Like

Yes. Working perfectly.
Thanks a lot.

Hello Hamel, I spent more than a week to set up correctly but no chance. My question is, is the article in the link is really has the correct information and works with fastpages as well? Did you try personally? It looks a general information about github pages. It is a very frustrating process, I try and wait for 24 hours sometimes 48 sometimes 72 hours and still get different types of errors.
Thank you

Ok, I messed up my blog while trying different solutions and setup from the beginning, this time worked well. I guess my problem was related to baseurl settings.

Hello @hamelsmu Thank you for this explanation. I did the fastpages things and it worked then I tried to convert everything to my custom domain and it failed.

@rakendd the way you listed out what you did helped a lot on my checklist of things to do to get my problems sorted.