Fastpages: sitemap and/or upgrade


I have this fastpage site ( which I am using through a custom domain:

Currently, Google search console does not seem to index it. Maybe it is not related to fastapges, but I still try to generate a sitemap and upload it to the search console.

I have read in github issues and here that there should be sitemap plugin in the config and perhaps a sitemap.xml somewhere. However, in my _config.yml I do not have that line and nor do I have that file in my repo.


First, I tried to manually add it to the plugin list, but that generated the following error:

Dependency Error: Yikes! It looks like you don't have jekyll-sitemap or one of its dependencies installed.
In order to use Jekyll as currently configured, you'll need to install this gem.
If you've run Jekyll with `bundle exec`, ensure that you have included the jekyll-sitemap gem in your Gemfile as well.
The full error message from Ruby is:
'cannot load such file -- jekyll-sitemap'
This text will be hidden if you run into trouble, you can find helpful resources at! 

Then, I managed to install it on my system, hoping that it will help (I have zero knowledge of Ruby :wink: ) but it resulted in the same issue.


Then, I tried to upgrade the repo but at the ‘sync baseurl’ step I got the following error message:

Run import re, os, yaml
/home/runner/work/_temp/ YAMLLoadWarning: calling yaml.load() without Loader=... is deprecated, as the default Loader is unsafe. Please read for full details.
  config = yaml.load(cfg)
Traceback (most recent call last):
  File "/home/runner/work/_temp/", line 25, in <module>
    settings['DEFAULT']['baseurl'] = config['baseurl']
KeyError: 'baseurl'
Error: Process completed with exit code 1.

As I am using a custom domain, my baseurl parameter in _config.yml is

baseurl: ""

In settings.ini this parameter first was

baseurl = /ds_blog

And I also tried to simply delete it (following the ‘3.’ “Special Instructions for baseurl” in config.yml)

baseurl =

But these did not do anything.

So, any ideas? :slight_smile:

Ok, since then I managed to actually read the error message I posted and realized that there is a thing called the Gemfile which I also should address. :man_facepalming: So now, I also included jekyll-sitemap there.

Now that did generate a sitemap in the local server but not online.

As I have read that sometimes it takes some time for it to appear, I just passed its url to the Google Search Console with some silly hope. Surpisingly it did find a sitemap but also threw an error:

This is not a valid URL. Please correct it and resubmit.

This then I resolved (based on this issue) by adding the full path (i.e. with ‘https://’) to the url parameter in _config.yml.

So this seems to be resolved. :man_dancing: