[fastpages] resources of the page won't load when use custom domain

I have follow the instruction on the fastpages document.
I have created a new repo which give me a page at https://[username].github.io/[repo] it works perfectly.
But when I set it up with custom domain (in repo setting page) the site show up with texts only but no resources files loaded they all got 404 when use chrome debug tool (F12) to view it. I don’t know what I did wrong?

Solved the problem. The solution is really simple

  1. when created the CNAME file only one subdomain is allowed e.g. www.example.com

  2. when modify _config.yml file
    the url: line should be the same as in the CNAME file
    e.g. url: “https://www.example.com

  3. and must comment out or delete the baseurl line this is the one that make all problem for me since when I comment this out
    the build action throw up these errors:
    check baseurl

errmsg = f"The value set for baseurl in _action_files/settings.ini and _config.yml are not identical. Please fix and try again."
assert config[‘baseurl’] == settings[‘DEFAULT’][‘baseurl’], errmsg
shell: /opt/hostedtoolcache/Python/3.7.9/x64/bin/python {0}
pythonLocation: /opt/hostedtoolcache/Python/3.7.9/x64
Traceback (most recent call last):

File “/home/runner/work/_temp/be40c2b2-6ad7-4332-8a26-b6b11b504785.py”, line 17, in
assert config[‘baseurl’] == settings[‘DEFAULT’][‘baseurl’], errmsg
KeyError: ‘baseurl’

##[error]Process completed with exit code 1.

which lead me to believe that comment out the baseurl is a bad idea and must avoid it.
But after run out of option to try I said what the heck just leave it on and low and behold it works!

I didn’t find that commenting out the baseurl line worked for me. I followed the instructions in the config file itself. That worked well for me.