[fastpages] jekyll build fails with plotly

Hi everyone,

I just installed fastpages and tried to upload a blogpost containing a plotly figure, but everytime the jekyll build would fail. When I remove the figure output it builds properly. Eventually, by look at the action output I figured out that the problem is related to the plugin jemoji. Switching off jemoji by removing its mention from _config.yml and Gemfile fixes the jekyll build problem. For my purpose that’s an acceptable fix, but some people might want to use both plotly and jemoji, so it might be worth fixing. Here is some more information:

Here is a notebook that can reproduce the bug (if jemoji as active):

as you can see, the notebook displays properly without jemoji:

Here’s the link to the Github action error:

and the same thing with jemoji off:

I did not attempt to build the blogpost locally.

1 Like

Just saw your post, I actually fought with the same issue yesterday and wrote another workaround here: [fastpages] Plotly plot doesn't load, JS error in browser .

I didn’t know it was related to jemoji though, so it’s nice that you figured that out since that might be an easier fix for some users. So it seems that we now have two workarounds:

  1. Disable jemoji in the config.yml / Gemfile

or 2) Add a special cell at the top of the notebook to disable the plotly_mimetype renderer and add the missing require.js

Indeed, it’s nice to have two possible fixes.

Many thanks for this work around @abauville - this worked like a charm, much more low friction way of getting plotly running on fastpages compared to other blogs / material out there

I’m glad I could help :grinning: