Fastai2 Cannoot import modules "ModuleNotFoundError: No module named ''"

I installed fastaiv2 from repo, install fastcore from repo.
Ubuntu 18.04. Python 3.7.3

I just came across the same issue, when import in Kaggle environment.

Me too! Did you guys find a solution?

Probably the Jupiter is not using the interpreter that has fastai2.
What solved for me was, after following all the steps of getting started installing guide
I created a new Jupiter kernel with the fastai2 conda environment, using those commands below

$ source activate fastai2
(fastai2)$ ipython kernel install --name "fastai2-kernel" --user

after that, just

  • refresh the browser which the Jupiter is running
  • Change the kernel to “fastai2-kernel” like this…
    Captura de Tela 2020-08-05 Ă s 11.34.33
    And now your are good to go!
    Captura de Tela 2020-08-05 Ă s 11.34.54

This link is not opening for me. Is it deprecated? :face_with_head_bandage: :sob:

Yes it is, but don’t worry now it’s straightforward to use the lib.
Just open a Google Colab notebook and run these two cells:
!pip install -Uqq fastbook
import fastbook

from fastbook import *
from import *

That’s it!

1 Like

The docs are now at, as fastai-v2 has been released, superseding fastai-v1.


1 Like

just install the latest version of the fastai library that exist at your time and the latest version of the fastcore library
pip install fastai==2.. fastcore==1..
and when importing just import from import * do not put fastai2
that worked for me

i installed fastai version 2.5.5 and latest fastcore library and imported as
from import * and it worked