Fastai v2 on Kaggle kernels

looks like fastai v2 library needs to be installed for each instance on kaggle notebooks, including restarting an instance. Any idea how we can permanently install it on all instances?
This is what I’ve done, and then I import any modules that I need.

!pip install fastai==2
import fastai


I’ve been trying to figure out how to update my (Older course-v3) kernels to the same, IMO this is the best approach^

1 Like

Hi! I just tried this approach but after the instalation I ran: fastai.__version__ to check it’s version and it still says ‘1.0.61’

Do you have any idea why is this happening?

This is very odd. You tried pip install fastai==2.0.0 and said it successfully installed it?

Oh I just tried again from a fresh session and it actually worked. My bad :sweat_smile:

1 Like

How can I install it using conda?

Another approach that doesn’t force 2.0.0 is

!pip install fastai --upgrade
1 Like

Do you want to install it on windows or kaggle?
For windows you can check and this might help on kaggle too.

Also i think the conda installation command on is broken, at least it did not work for me. The way I got it to work was by cloning fastai repo on github and using pip install. But before that you’ve to install cudatoolkit and pytorch using conda

I wanted to install on kaggle. Thanks a lot, good to know.