Fastai 1.x on cpu on mac

Previously I setup v0.7 using the instructions in the readme.

conda env create -f environment-cpu.yml

But for v1.x that file has been updated to say

for fastai-1.0+ edit "" and use "pip install -e ."

Does this mean I don’t use conda anymore? Everything I’ve seen before seemed to indicate conda OR pip.

I did run the pip install in the fastai dir and it seemed to work even though I didn’t have to edit Maybe it just figures out that I’m on a CPU (macbook) and does the right thing?

I then cd to my course-v3 repo and it worked!

Anyway, thought others might find this helpful.


Does this mean I don’t use conda anymore?

I’ve used conda to install fastai 1.0.41 on my Mac into a conda environment, although I’m not using a .yml file to do it.

after creating a conda environment, activating it, and installing dependencies (using conda or building from source), I installed the latest fastai using

conda install -c fastai fastai

I currently have fastai 1.0.41 installed, although I see the latest via that channel is now 1.0.42. I had to build PyTorch 1.0 from source though, as I wanted to use it with CUDA (with an eGPU), which complicated the setup. I haven’t tried using pip or mixing use of conda and pip, so can’t comment on that.