Fastai 1.0.6 not working in kaggle

after the latest upgrade of kaggle with fast ai version 1.0.6
All imports are failing,tried installing old version but every time reinitiazing puts the latest version in place…
any solution ?

It looks like there’s a workaround here, you can install pre-v1 fastai from the notebook: Kaggle kernel error - ModuleNotFound error importing 'fastai.structured'

1 Like

that wont help i guess… because i tried it dsnt works… kernel reinit with same environment, only workaround i could find is using old image of python docker but it takes long time to load it whenever kernel reinitializes.

Hi Jaideep,

Could you share how you loaded an older python docker image…?
How long was a long time … for the kernel to reinitialize…?


Hi William,

I tried out the kaggle kernels shared at

They were great… I was able to run them in one form or the other till last week, Today the imports fail, I did try the work around you shared in the lost above… that didn’t work.

I think a lot of other users have been facing similar issues, with posts as recent as 15 hours [as of this posting] querying about it.

Any ideas/workaround for this issue…?


fast ai - latest version. Imported all required files still throwing this Error
Error: name ‘ImageDataBunch’ is not defined

hi rony
if you had ever used fai 0.4 in kaggle kernel,then in Docker drop down there should be an old snapshot of python docker available select the one prior to update of FAI version. If your kernel is new then you will not have any snap shot.
Only workaround is include pip install fai 0.7 in very first block . It dint work for earlier now it works,but then every time u open the kernel u need to run the block.

1 Like

No Joy… :frowning:
For changing the docker on the right hand side, settings section, is there anything i need to do after selecting an older docker…? [i did nothing, the notebook got saved and the issue still remains…]

tried it for other docker images… grand total of 4… no effect

all the dockers had the same structure for fastai : dir(fastai) in a notebook cell… you can see imports but none of the other files…

which are listed here

should i be worried that these files are moved to a path with ‘old’ in it…? :slight_smile: …?

the other workaround, pip install fastai== 0.7 it installs 0.7 yes, but it still doesn’t restore the missing imports/ files that need to be imported…