Fast AI V1 on Kaggle Kernels now, but `torch` not compatible

According to this post 3 days ago, it was still the old fastai, but it looks now like version 1 comes default with Kaggle Kernels now.

Output of import fastai; fastai.show_install(1):

platform   : Linux-4.9.0-5-amd64-x86_64-with-debian-8.9
distro     : #1 SMP Debian 4.9.65-3+deb9u2 (2018-01-04)
python     : 3.6.6
fastai     : 1.0.6.dev0
torch      : 0.4.1
torch cuda : Not available
torch cuda 
nvcc  cuda : Unknown
torch gpus 
no supported gpus found on this system

I did have the GPU turned on when I ran this (according to the web-UI). I’m not sure why it’s not showing up.

I ran torch.cuda.current_device() and got this:

    AssertionError: Torch not compiled with CUDA enabled

I wasn’t able to duplicate any training from the docs after a few minutes. I had some other issues in playing with it, but I’m sure a lot of that “will come out in the wash” as the saying goes. Let me know if this sounds worth pursuing and I don’t mind posting more at all.

Yeah you might want to send a PR to their repo to force fastai<1, or ask them to include pytorch v1 gpu in their repo.

I’m facing the same issue. @bhollan please update here if you have managed to send a PR and solve it… Even on google colab, fastai 0.7 is throwing up tensor float32 error. Unfortunately, I have updated my laptop to fastai 1.0. Kaggle is my only hope left.

Looks like fastai 1.0 dosent have ColumnarModelData, it’s changed to ColabFilteringDataset. I think I’ve to port the class definition into a cell and make sure its pytorchy 0.4.

I using this notebook as a reference,a getting Can only use .cat accessor with a 'category' dtype as the error while spiting into input pandas frame into train_ds and val_ds.

This helped me out … Kaggle kernel error - ModuleNotFound error importing 'fastai.structured'

Brian, I’ve googled that AssertionError, and in every case I’ve seen, it always was triggered by the same command: ‘current_device()’. So I’m trying to avoid using that command.