Fast-ai pytorch verison compatibiltiy


  1. When I try to install fastai 2.3.1, with pytorch 1.9 release candidate, I get warning that
    fastai 2.3.1 requires torch<1.9,>=1.7.0, but you have torch 1.9.0 which is incompatible. Will fast ai release new version which would be compatible with pytorch 1.9?

  2. If I install fastai 1.0.61 with pytorch 1.9 release candidate, I do not get any such warning. Does this mean fastai 1.0.61 is compatible with pytorch 1.9 or it is incompatible but warning is not printed?

Where can I find pytorch-fastai compatibility table?


you can check in the settings.ini on GitHub which torch version (or other libraries versions) is compatible with fastai: fastai/settings.ini at 90e009b90b9843dde8c02b0268ab9021ebef342f · fastai/fastai · GitHub

Fastai v1 is probably not compatible with PyTorch as it is no longer actively maintained, and PyTorch 1.9 came out long after the last update on fastai V1. It seems it just does not warn you.

1 Like

Thank you @BresNet . Is there any plan or expected date by which fastai will support pythorch 1.9?