EVGA RTX 2080 Ti runs fastai in Windows10, fails in Ubuntu18.04

Hello everyone,

Just received a refurbished EVGA RTX 2080 TI FTW3 Hybrid from EVGA for an RMA’d unit. When trying to run lesson1-pets, it kicks out, “RuntimeError: CUDA error: an illegal memory access was encountered” at “learn.fit_one_cycle(4)”.

EVGA doesn’t officially support UBUNTU so the CS rep asked me to try it in Windows. After setting up FastAI in Win10, I ran lesson1-pets. The GPU works in Windows10, though it is 3x slower than an identical GPU running fastai in ubuntu on the same system.

Rebooted and tried again in Ubuntu and received the same RuntimeError when trying to run lesson1-pets. It’s able to run the Cuda samples and pass Cudnn’s mnist.

My other RTX 2080 Ti (same make and model) works great on both OS’s.

Is it a card setting?

Any ideas?

Here’s the dual boot setup,

CPU: I7-6700K
MOBO: MSI 7968-001R


  • fastai 1.0.61
  • cudatoolkit 10.1.243
  • nvidia driver - 432.00
  • python 3.7.7
  • pytorch 1.6.0

Linux 18.04:

  • fastai 1.0.61
  • cudatoolkit 10.1.243
  • nvidia driver - 440.100
  • python 3.7.7
  • pytorch 1.6.0

Thanks for your patience and assistance, I’m new.

As a data point, I’ve running the fastai2 (1v4) course on Ubuntu 18.04 bionic with EVGA GeForce RTX 2080 Ti GAMING, 11G-P4-2380-KR, 11GB GDDR6.

I haven’t tried this setup recently. But it was working fine 1.5 months ago. Note, I don’t think I’ve run that lessons1-pets before. But everything I tried on 1v4 ran well.

  • fastai 1.0.60
  • cudakit 10.1.243
  • nvidia driver 435.21
  • python 3.7.7
  • pytorch 1.4.0

I might run update/run something tomorrow. I’ll update this if I do.

Thank you very much @DanielLam!

I’ll try your suggestion and report the results.

I ended up deleting my cuda installation, and reinstalling it haha. Ran some old notebooks, no issues and training time was the same.

  • fastai 1.0.60 updated
  • cudakit 10.1.243
  • nvidia driver 450.51.06 updated
  • python 3.7.7
  • pytorch 1.6.0 updated

Whoa, life got in the way.

Thank you so much for your suggestions which I tried. Turns out my card was bad and EVGA graciously replaced it under warranty. EVGA’s customer service is awesome and their cards are even better.

Take care.