ERROR: google-colab 1.0.0 has requirement pandas~=1.0.0; python_version >= "3.0", but you'll have pandas 1.1.1 which is incompatible

Hi everyone.

This is a followup to my last issue. When I run

!pip install -Uqq fastbook
import fastbook
fastbook.setup_book()

I encounter the following issue:

ERROR: fastai 2.0.6 has requirement pandas>=1.1.0, but you'll have pandas 1.0.5 which is incompatible.

My best guess for a solution is to install an updated version of pandas, yet i’m not sure how to do this.

Any help is appreciated.
Thank you.

Issue fixed with:

!pip install pandas==1.1.0

9 Likes

For me, installing pandas before fastbook gave me new conflicts and a new message to restart runtime. It didn’t work after that anyways.

I was better off with installing pandas later.

!pip install -Uqq fastbook
!pip install pandas==1.1.0
import fastbook
fastbook.setup_book()
6 Likes

It works very well. Thanks!

1 Like