Error Displaying Widget

I’ve scoured this forum and others have had the issue of widgets not displaying in JupyterLab/Notebook. I’ve tried just about every suggestion and still no luck.

Here are my core package versions

Selected Jupyter core packages...
IPython          : 8.24.0
ipykernel        : 6.29.4
ipywidgets       : 7.8.1
jupyter_client   : 8.6.1
jupyter_core     : 5.7.2
jupyter_server   : 2.14.0
jupyterlab       : 4.1.8
nbclient         : 0.10.0
nbconvert        : 7.16.3
nbformat         : 5.10.4
notebook         : 7.1.3
qtconsole        : 5.5.1
traitlets        : 5.14.3

I get no explicit error messages and the images show up in the console Log Level: Debug

I have tried updating to the latest ipywidgets - but get the error that states it must be below version 8 to work with fastbook.

I have followed he suggestions outlined Lesson 2: ImageClassifierCleaner - Error Displaying Widget - #3 by dawg89 and ImageClassifierCleaner UI doesn't update - #8 by evanemolo with no luck.

Every other command seems to work so far except for the widgets

Any help or guidance would be greatly appreciated!

UPDATE:

And just like that, by downgrading to JupyterLab 3.6.7, it worked :upside_down_face:

Hopefully this can save others from searching forever