Draw_tree in 09_tabular got truncated

see my screenshot, when I run the draw_tree cell, my output is truncated, and I don’t see any horizontal/vertical scroll bar…

1 Like

it is a little weird, my previous run was on a non-GPU machine.
this morning, I tested the same code in another GPU machine, the output works well.

and I tested again on non-GPU machine, still not works.

I rm -fr ~/anaconda3/ folder, and re-install everything, this issue gone.

Having the exact same problem on my desktop (which has an Nvidia RTX 2070 Super GPU, in any case, so I strongly suspect that’s not the decisive variable here). I did follow the instructions at the dtreeviz GitHub page – i.e. I uninstalled my Anaconda versions of graphviz and python-graphviz before installing the pip version of dtreeviz. Perhaps there’s something wrong with the version of graphviz used with dtreeviz?

not sure, I just checked my install shell, after rm -fr anaconda3 folder,
I run this script:

and here is the install_fastai.sh

from install_fastai.sh
I used pip to install dtreeviz, and later use conda to install graphviz…

there must be sth wrong in the version between this packages, but I don’t know how to fix it gracefully.
that’s as far as I could help you, and myself in future

maybe we could file an issue to dtreeviz ? so they could provide a graceful fix.
and if you found a better solution, remember to share with me.

I had the same thing happen, and a fix that I hit upon was to remove the “size=7” parameter from the function call.


Thanks, Andrew. Finally, I’ve got the right thing by dropping “size=7.”

Spot on my friend. Thanks :slight_smile: :smiley:

@huangyingw please accept this as the right answer. Thanks. :slight_smile:

1 Like

Thanks a lot!!!