Download_data() got an unexpected keyword argument 'ext'

#1

Got this error when trying to download_data in the 01_matmul notebook. I’ve tried git pulling and updating FastAI

Info from importing fastai,utils.collect_env

=== Software === 
python        : 3.6.8
fastai        : 1.0.48
fastprogress  : 0.1.20
torch         : 1.0.0
nvidia driver : 396.44
torch cuda    : 9.0.176 / is available
torch cudnn   : 7401 / is enabled

=== Hardware === 
nvidia gpus   : 1
torch devices : 1
  - gpu0      : 12210MB | GeForce GTX TITAN X

=== Environment === 
platform      : Linux-4.4.0-21-generic-x86_64-with-debian-stretch-sid
distro        : #37-Ubuntu SMP Mon Apr 18 18:33:37 UTC 2016
conda env     : fastai-please-work
python        : /home/ray/anaconda3/envs/fastai-please-work/bin/python
sys.path      : /home/ray/anaconda3/envs/fastai-please-work/lib/python36.zip
/home/ray/anaconda3/envs/fastai-please-work/lib/python3.6
/home/ray/anaconda3/envs/fastai-please-work/lib/python3.6/lib-dynload

/home/ray/anaconda3/envs/fastai-please-work/lib/python3.6/site-packages
/home/ray/anaconda3/envs/fastai-please-work/lib/python3.6/site-packages/IPython/extensions
/home/ray/.ipython

Thu Mar 28 13:58:34 2019       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 396.44                 Driver Version: 396.44                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX TIT...  Off  | 00000000:01:00.0 Off |                  N/A |
|  0%   51C    P0    56W / 250W |      0MiB / 12210MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|  No running processes found                                                 |
+-----------------------------------------------------------------------------+

0 Likes

(Ben Mainye) #2

Hey! @Raymond-Wu try to download the latest version of fast.ai + pytorch and that will fix it. At least it has worked out for me. Just in case, here some script you could run on your terminal or jupyter cell

!pip install torch_nightly -f https://download.pytorch.org/whl/nightly/cu92/torch_nightly.html
!pip install fastai
!pip install fastai --upgrade

remove the exclamation mark when running in the terminal.

1 Like

(Less ) #3

1 - bonus points to you for your conda environment: “fastai-please-work” lol.

I’ve been fighting the same problem though, it’s a change in datasets.py, download_data that isn’t being picked up in your install (or on Floydhub for that matter).

This line was the fix for me - thanks Radikubwa!:

pip install fastai --upgrade
1 Like

(Ben Mainye) #4

You’re welcome. I use floydhub too. Mostly a yaml file with a fixed version of fastai works well too. @LessW2020

0 Likes

(Less ) #5

Hi Radikubwa,
Would you mind posting out your floyd.yml you are using for the FastAI course? I have only briefly read how their auto-config /setup works, and if you’ve got it setup and working already that would be a big help for me (maybe others as well).
Thanks very much!

0 Likes

(Ben Mainye) #6

Hey @LessW2020 sorry to keep you waiting. What’s strange is that the error comes up on cells in my notebooks too. Also, if you check out this https://course.fast.ai/update_floydhub.html it should work. I setup my workspace to include the floyd_requirements.txt and floyd.yml yet the error persists like shown here https://github.com/fastai/course-v3. To be fine just include a cell with the above pip installs I have mentioned @whatrocks how can i fix this problem? without the !pip install files above in a certain cell i’m still getting the error above. Please assist.

1 Like

(Charlie Harrington) #7

Hi! Yes, you’ll need to upgrade the version of fastai each time you run your workspace on FloydHub, since the environment doesn’t always have the latest version of fastai installed automatically.

1 Like

(Kyle Nesgood) #8

I’ve updated my environment to the latest version and am still getting the same error. Any ideas on what else to look at to troubleshoot?

0 Likes

#9

If using conda, I found “conda install -c fastai fastai” works too. Just another way to update fastai

0 Likes