Not if you do
git pull. I have experienced this problem several times.
I think the best solution is to assert for a specific fasprogress version in the fastai code (and not just package dependencies). That way regardless of how people get their fastai updates, they will know right away that they need a newer version of fastprogress.
It doesn’t look this is common in python to perform that at the code level. Or at least I couldn’t find almost any references on how to do it, or even people asking about how to do it.
I found this suggestion:
import pkg_resources pkg_resources.require("fastprogress>=0.1.18") import fastprogress
And if the version is insufficient, you’d get:
python -c 'import pkg_resources; pkg_resources.require("fastprogress>=0.1.19"); import fastprogress' Traceback (most recent call last): File "<string>", line 1, in <module> File "/home/stas/.local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 898, in require needed = self.resolve(parse_requirements(requirements)) File "/home/stas/.local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 789, in resolve raise VersionConflict(dist, req).with_context(dependent_req) pkg_resources.VersionConflict: (fastprogress 0.1.18 (/home/stas/anaconda3/envs/pytorch-dev/lib/python3.6/site-packages), Requirement.parse('fastprogress>=0.1.19'))