Deployment Platform: Render ✅


(Abdu Issa) #63

Update to this—I deleted the repo and re-forked it. This time I didn’t change the name of the repo in my fork. Now it works great. Very cool service!

Wonder if forking the fastai template means I can’t rename the repo…?


(Jeff C) #64

I had updated fastai on my GCP vm instance and made sure it is on version 1.0.42. For some reason, I am still stuck with the same error. I even tried using a different server on Gradient instead of GCP. Again, I followed the Back to work instructions to update fastai to 1.0.42 and generated a new export.pkl.

I verified the download link worked correctly, but again got the out of date error.

Here’s my notebook output on Gradient with fastai 1.0.42. Am I not using learn.export() correct to output the pkl file needed for Render?


(Pierre Guillou) #65

@anurag: yes. My computer is on Windows 10. Then, I use Anaconda Prompt as terminal.
My environment:

python : 3.6.8
fastai : 1.0.42
fastprogress : 0.1.18
torch : 1.0.0
torch cuda : 9.0 / is available
torch cudnn : 7005 / is enabled
platform : Windows-10

I do not use Jupyter on Linux.


(building render.com) #66

It looks like there might still be some unresolved issues in fastai 1.0.42. See this comment and open issue: https://github.com/fastai/fastai/pull/1502#issuecomment-459165078


(Jeff C) #67

Thanks, @anurag. I will step away from this for a while and come back later then. It’s good to know that I am not going crazy. Haha!


(building render.com) #68

You’re absolutely right! We’ve now enabled Docker caching, so it shouldn’t build the whole thing every time. This halved the build time for the example repo.


(Maxim Pechyonkin) #69

Today I spent some time to deploy my leafy greens classifier.

My feedback:

  • I like that it will automatically redeploy the app whenever I push any change to the repository.
  • No hassle and very easy. I’ve never deployed a model to production, I am not familiar with Docker, nor with web development. So your service was a pleasure to work with.

I will definitely recommend it.


(building render.com) #70

Really great to hear!


(Vikash Pathak) #71

I am also getting the same error…how did you solved it??


(building render.com) #72

We’re waiting for the next release of the fastai library. Until then, try using a dev install using the command here: https://github.com/fastai/fastai/pull/1502#issuecomment-461227188


(building render.com) #73

Heads up: fastai 1.0.43 has been released, and the CUDA issues shouldn’t be a problem if you upgrade and export your .pkl file again. I’ve also updated requirements.txt for the sample repo to include the latest version of fastai and pytorch for Linux.


(Edward Easling) #74

I was having the same problem as @pierreguillou, @abduissa and @Vikash , and it turns out that the direct download link to the export.pkl file was not working. I was using the direct link generator in your tutorial (https://course.fast.ai/deployment_render.html) but it was generating bad links. Once I used a different link generator, my issue disappeared


(Chris Pontarolo-Maag) #75

I just got Render to work on a sample shoe dataset and am loving it! The ResNet34 model works great on my Mac, but when I try to analyze a photo using my iPhone, it seems to get stuck on ‘Analyzing’. Any tips on how to make the mobile performance return a result more quickly? For reference, in Chrome on my Mac, it takes ~5-10 seconds for the model to return a result. On my phone, it seems to be stuck on the analyzing step. On mobile, I tried both Chrome and Safari browsers, and both are having the same issue.


(building render.com) #76

Could you post the link to the generator? I’ll update the docs.


(Edward Easling) #77

https://www.wonderplugin.com/online-tools/google-drive-direct-link-generator/


(marsen) #78

I am using the guide to deploy example fast.ai-v3(https://github.com/render-examples/fastai-v3).And I came to this error:


(Chris Pontarolo-Maag) #79

What version of the fastai library are you using? I had some issues until I updated my version with pip install --user fastai --upgrade


(marsen) #80

Thank you.But i am deploying it in render,i can not change something.
I am following this guild https://course.fast.ai/deployment_render.html


(Chris Pontarolo-Maag) #81

Yes, I had a similar issue. My issue was Render couldn’t find fastai v 1.042 or greater (something like that). When I upgraded the library (within GCP) and exported the pickle file again, then it worked.


(marsen) #82

Thank you. But i didnot use GCP in this case .I solve this problem by doing this:

  1. edit the file “requirements.txt” in the project u just forked (fastai-v3)
  2. modify “fastai==1.0.43” to “fastai==1.0.42”
  3. commit it.

Then u can deploy again.it works now.