Cycle GAN Data Load Question


(Phil Weslow) #1

I am working on getting the Cycle GAN notebook up and running and having difficulty loading the data. When I run the following cell…

I get the following error:

AssertionError: /data0/datasets/cyclegan/horse2zebra/trainA is not a valid directory

In my dl2 directory, I have the cgan directory which contains the data directory. But that folder contains several Python files and no directories. It certainly does not contain a datasets directory.

I’d love to get up and running with this notebook, but I’m a bit at a loss regarding how to proceed.


(tester) #2

read the last comments in this file. there is a download link


(Phil Weslow) #3

Thanks for the tip! Weird that they put it at the bottom of the file!

#! wget https://people.eecs.berkeley.edu/~taesung_park/CycleGAN/datasets/horse2zebra.zip


#4

Hi Phil:

I put the datasets folder inside the data directory within the can directory, I still got the same error.

Where shall I put the datasets/cyclegan/horse2zebra folder?

Looking forward to dirty socks reply. Thanks a lot


(Phil Weslow) #5

Sent you a PM.


(Joshua Lelon Mitchell) #6

I, too, would like to know where to put the datasets/cyclegan/horse2zebra folder. :slight_smile:

Specifically, where does the dataloader think /data0/datasets/… is, so I can put that dataset I just downloaded there (i.e. the place it thinks it is)?

I don’t know if there’s a best practice for this, but I got it to work by just unzipping the images into a folder, opening that folder in a terminal, typing pwd, and copy and pasting the directory pwd spit out into the model’s opt parameter.