Crestle [easier alternative to AWS]

(José Fernández Portal) #103

I started using Crestle. First, I found that Theano was not installed. After installing it, when running “import theano” I get this error “You are tring to use the old GPU back-end. It was removed from Theano. Use device=cuda* now. See for more information.”. I tried to set device=cuda in $HOME/.theanorc, but it didn’t work. Hope you can help me.

(Sebastian Gonzalez Aseretto) #104

I’m having the same exact problem, has any one solved it?

(Anurag Goel) #105

Have you installed keras 1.2.2? It is needed for the course and automatically installs the supported Theano version.

I’d recommend uninstalling the Theano version you installed and following the instructions here:

(Sebastian Gonzalez Aseretto) #106

I just did what you said, and also a friend did the same when trying for the first time Crestle, and we are still getting an error when running that notebook with enable GPU. The curious thing is that when running the instance without “Enable GPU” the import of utils works, but then it throws an error when trying to train the model.
The error I’m getting when running crestle with GPU is the following.

ValueError: You are tring to use the old GPU back-end. It was removed from Theano. 
Use device=cuda* now. See for more information.

(Anurag Goel) #107

It should work if you install the previous version of Theano:

pip2 install theano==0.9.0

(Krunoslav Vinicki) #108

I got this error: Unreadable Notebook: /home/nbuser/courses/fastai/deeplearning1/nbs/lesson1.ipynb NotJSONError('Notebook does not appear to be JSON: ‘{\n “cells”: [\n {\n “cell_type”: "m…’,)

Can you please help? I can open other lessons. Problem is with just lesson1

(Sebastian Gonzalez Aseretto) #109

Thanks a lot for the help Anurag!
Everything is working now. I’ll summary everything so that if anyone has the same problems will know how to solve it. For anyone who is trying to run the original notebooks of part 1 from the course, first you will need to run the following commands in the terminal

pip2 install keras==1.2.2 theano==0.9.0

and then

mkdir -p ~/.keras
echo '{"epsilon":1e-07,"floatx":"float32","backend":"theano", "image_dim_ordering": "th"}' > ~/.keras/keras.json

Also this can be included in the notebooks the same way anurag included it in the crestle-fastai notebooks here:

If you have already installed theano before doing this steps, you will probably encounter an error like this:

ImportError: cannot import name inplace_increment

To solve this, uninstall that theano and delete the theano-cache running theano-cache purge or deleting it manually with rm -rf ~/.theano
and then install the theano version 0.9.0

(Sebastian Gonzalez Aseretto) #110

I had the same error, what I did was to upload myself the notebook from lesson1 that Anurag posted, and it worked as intended. If you want to run the original notebooks maybe you will need to install the packages with the terminal before running any notebook

(Krunoslav Vinicki) #111

tnx, that solved the problem :slight_smile:

(Anurag Goel) #112

As an update, Crestle includes Theano 0.9 as the default for now. When the new version of the course is released in a few weeks we can stop using Theano/Py2 altogether.

(Giulio Matteucci) #113

Hi @anurag!

I was wandering if you already managed to solve the issue with jupyter themes already reported by @mosessoh.
I tried to use jupyter themes on crestle and I encountered the same problem… Is there any workaround?

(Anurag Goel) #115

I haven’t yet. Which theme are you looking to use?

(zest er) #116

Hello @anurag,

I am having problems downloading data from Kaggle (the carvana-image-masking-challenge). I have tried the kaggle-cli (install, kg download etc …). Is it not possible to use the kaggle-cli on Crestly?
I have also tried wget as recommended in your site. The wget works on the cifar example you provide in your FAQ. But I am not able to download the Carvana data. This is a sample command I use (I have tried other versions):


An empty file is downloaded in the first instance, the index page in the second.

I have written to support@crestle a few times so you will see my question there as well. I have found my deep learning setup on AWS to be very frustrating which was why I was trying out Crestle.

(Anurag Goel) #117

I wouldn’t use wget for this because it does not send your Kaggle auth credentials by default. In the terminal, try upgrading your version of kaggle-cli:

pip3 install -U kaggle-cli

# followed by

kg download -u <username> -p <password> -c  carvana-image-masking-challenge

Replace <username> and <password> above with your details. If this doesn’t work, please post the output of the commands above.

(Giulio Matteucci) #119

I like “grade3”

(zest er) #120

Thanks. Yes “pip3 install -U kaggle-cli” did the trick. I had tried “pip install -U kaggle-cli” before. Perhaps you can include information about kaggle downloads in your FAQ.


I want to use Caffe on Crestle, but I cannot use the ‘sudo’ command which shows that not permitted. How can I fixed this, And how can I use ‘Tensorboard’ on Crestle? Thx.

(Anurag Goel) #122

Caffe can’t be installed manually on Crestle at the moment because it requires admin privileges. I’ll look into adding it to the base image soon. Tensorboard isn’t supported, since it’s a Jupyter-only environment for now.

(Anurag Goel) #123

I’ll plan on adding support for user-installable extensions and themes to Crestle.

(Giulio Matteucci) #124

Thank you, it would be great!