CPU based fastai


(Gerardo Garcia) #1

Jeremy mentioned during the video a CPU based fastai
Where is that?


(Sharwon Pius) #2

Make a conda enviornment using this.

To install a cpu only environment instead:

  • cd fastai
  • conda env update -f environment-cpu.yml

click – > enviornment-cpu.yml


Exposing DL models as api's/microservices
(Kaitlin Duck Sherwood) #3

FYI that didn’t work for me on a Mac. I got

ResolvePackageNotFound: 
  - pytorch >=0.2.0
  - mkl >=2018

Which isn’t that surprising, I guess.


(WG) #4

Depending on what version of the OS you are on, you may have to install an older version of opencv-python.

I’m on 10.10.5 and had to do the following:

pip unintstall opencv-python
pip3 install opencv-python==3.2.0.6

(Jeremy Howard) #5

Not sure why pytorch isn’t working, but you can certainly comment out the mkl line in the yml - that’s optional.


(WG) #6

@Ducky … I’m on a mac too here at work.

If you have an existing fastai environment, I’d suggest removing it and then following these steps:

cd fastai
conda env create -f environment-cpu.yml

If you have problems with opencv, see my previous comment here.

Once everything installs …

# conda env update -f environment-cpu.yml as needed
source activate fastai-cpu

The only problems I’ve encountered on my Mac is when trying to use the GPU.


(Kaitlin Duck Sherwood) #7

Thanks, it turned out that I had to update conda, then everything worked. <3


(K Sreelakshmi) #8

On Mac 10.13.3, fastai cpu env installation worked normally.


(Aritra Sen) #9

getting the above mentioned error while running the conda env update -f environment-cpu.yml on windows , any help would be appreciated.