Course 2019 - lesson 4 - data.show_batch() keep running and never ending

As I’m trying to run the lesson4-tabular notebook, I’d like to check the loaded data just like it is shown but when I activate the code cell it just keeps running like :

On the second cell you can see it keeps working and never ending, is it just me or is there anybody else having the same issue ?

I’m working with the last version of fastai on my windows 7 computer only with a CPU

EDIT : it seems to be the same trouble when I try to launch the fit() method for my learner, it runs but never start anything

Did you install the CPU build?:

Yes I tried it, but now I’ve another issue with “TabularList.from_df()” :

AttributeError: ‘DataFrame’ object has no attribute ‘isna’

But I can’t modify the method, is there something I need to reinstall maybe ?

That error is coming from pandas so something may be wrong with your pandas installation

Alright ! It finally worked after installing cpu PyTorch package and updating pandas package

Thank you very much for your help !

no problem! Glad I could help.