Confusing on how to download image[Chapter 2: clean]

Hello, everyone

 Today I tried to download pictures from "search_images_ddg" command as follow

The problem is I didn’t get any pictures in (fns). I dont know why, but I think the problem is around the yellow highlighted.

Cound someone help please ? Thank you so much

Without the name of the notebook you were using and the error it will be difficult to help. Your jpg was fuzzy and unreadable when I tried to show it. Please give as much information on your problem as possible when asking for help.

1 Like

Thank you so much for answering, Mr.Interogativ and I apologies

I wonder if will you be able to access my notebook though this link ?

There are a couple of problems here. I’m not sure what version of fastai you’ve installed, but the reason you’re coming up empty is because the search_images_ddg method is not returning any data. If you look above you’ll see that the parameter to that method is ‘grizzly bear’ not ‘Path’, f’{o}’ bear’ get rid of the ‘Path’ and it should work. the f’{o} bear’ is a format string that turns the o in for_bear_types expression to ‘grizzly’,‘black’ or ‘teddy’ from the list. Also the search_images_ddg method doesn’t work in some fastai versions. To try your notebook, I had to download and update the method in my release.

wow thank you so much for answer !:smiley:

I will defimately try to figuring it out