Conda update issues?

Is anyone else having errors when updating the fastai packages via conda?

All was ok for me before but now getting errors like the below for anything from fast ai, packages outside of fast ai still update ok

conda update -c fastai fastai
Solving environment: failed

>>>>>>>>>>>>>>>>>>>>>> ERROR REPORT <<<<<<<<<<<<<<<<<<<<<<

Traceback (most recent call last):
  File "/home/ubuntu/anaconda3/lib/python3.6/site-packages/conda/core/", line 227, in _load
  File "/home/ubuntu/anaconda3/lib/python3.6/site-packages/conda/core/", line 574, in fetch_repodata_remote_request
    raise Response304ContentUnchanged()

During handling of the above exception, another exception occurred:



I don’t know which platform you’re on, but assuming you’re on AWS, the Returning to AWS page from course v3 site indicates the following commands:

conda update conda
conda install -c fastai fastai

From what I can see, the commands to update the fastai packages are similar on other platforms. So I suggest you try replacing update with install in your command.

1 Like

Thanks Antoine, conda was already up to date but it worked ok with install today. Back up and running again, thanks!

Hello. I installed fastai v1 with conda on my Windows 10.
Works well but when I type in my Anaconda Prompt (with my fastai v1 environment activated):

  1. conda search -c fastai fastai, I can see that that the last version is 1.0.41 (build=1).
  2. conda list fastai, I see that my version is 1.0.38 (build=py_1)

Then, I tried to update fastai v1 by running conda install -c fastai fastai (I did try as well conda update -c fastai fastai), but I got back All requested packages already installed and my fastai v1 version is still 1.0.38, not 1.0.41

How to get the 1.0.41 with conda ? Thanks.

Hi Pierre,

I recently experienced the same issue. I think I solved it using this command (see this post):

conda install fastai -c fastai -c pytorch

Hello Antoine. Thanks but it does not work for me (I’m using Anaconda Prompt in my Windows 10).
Neither with update (conda update fastai -c fastai -c pytorch).

@Antoine: @willismar found the solution :slight_smile: