ClassConfusion throwing an AttributeError


I’m currently going through Lesson 2 using the ClassConfusion class in Google Colab in the following way:

ClassConfusion(interp, classes, is_ordered=False, figsize=(8,8))

When I ran the cell, I was asked to enter a value for ‘k’, or the top images you will see. I didn’t know what this was about so I entered 5. I was met with the following error message:

  0%|          | 0/3 [00:00<?, ?it/s]  0%|          | 0/3 [00:00<?, ?it/s]
AttributeError                            Traceback (most recent call last)
<ipython-input-22-6a81612b4be5> in <module>()
----> 1 ClassConfusion(interp, classes, is_ordered=False, figsize=(8,8))

4 frames
/content/ClassConfusion/ in _plot_imgs(self, tab, i, **kwargs)
     92                 img, lbl =[idx]
     93                 fn =[idx]
---> 94                 fn ='([^/*]+)_\d+.*$', str(fn)).group(0)
     95       [row, col])
     96                 ax[row,col].set_title(fn)

AttributeError: 'NoneType' object has no attribute 'group'

I know that we can’t really use widgets in Colab but I was under the impression that ClassConfusion would remedy that problem. Its my 1st time ever using it and I am a newbie so this is most likely on me.

Thank you.

Can you open an issue on my repo please? :slight_smile:

Sure thing :slight_smile:

In the mean time, how can I run the widget on the Jupyter in my own server? I am running the ResNet34 cycles on Colab because I don’t have a GPU so what is the way to use those weights in my local machine?