Can't run

$ bash line 1: syntax error near unexpected token newline' line 1:

i saw there are some threads on this but i couldn’t find anything conclusive. i would guess this error is about formatting of the script file. i opened it and didn’t see anything obvious even when i revealed hidden chars. how are people dealing with this now? thx

What platform are you running on?

Perhaps you can try the CLI tools ‘dos2unix’ on it to strip out any special characters (if that is the case).

Same problem. Here is my terminal output. Ignore Deeps-MacBook-Air:~ deep-mind

Deeps-MacBook-Air:~ deepmind$ bash
True line 13: /Users/deepmind/.ssh/aws-key.pem: No such file or directory
chmod: /Users/deepmind/.ssh/aws-key.pem: No such file or directory

An error occurred (InvalidAMIID.NotFound) when calling the RunInstances operation: The image id ‘[ami-bc508adc]’ does not exist
Waiting for instance start…

The script cannot run further.
Must my region be Oregon for the script to work? The region I set is Asia Pacific-Singapore.

I am having the same issue. Any ideas how to fix this error.

Or is there any other way to create AWS AMI for the course?

Pretty sure you have to use the region they provided as I believe that is what the AMI is associated with. I had left it to ‘us-east-1’ and didn’t work.

Hi Guys!
I am experiencing the same issue (Frankfurt), but could not find the AMI in the Ireland region neither.
As it seems from my experimentations it is only available in the Oregon region.
Could you please publish the AMI in the other regions too, please?

Hi there,
I am facing issues with the download of the file from github (can’t log in on, even so I do have an account). The file is downloaded as an html file as the lenght is unknown. Does anybody have an idea?
Thanks. Denny

I fixed my own issue by cloning the git repository. Now the installation works fine. If you have further questions please contact me.

Can you please list the steps that you took to fix this issue?

@Pawan36, I downloaded the git package, and cloned the depository afterwards, copied the necessary files in the Cygwin directory, and bam it worked.

Before that I tried the raw-data wget - didn’t work for me.

I hope I could be off any help.

Guys, could somebody take a look on this?
Sharing the AMI with other regions should not take more than 5 minutes if someone has the privileges, but it is blocking me with starting the course.
Please, help.

Here’s how I solved the ‘syntax error near unexpected token newline’: Can’t Run; Help With Bash