Can't run jupyter notebook on Linux Server

I’m trying to set up my linux server on AWS following AWS EC2 | Practical Deep Learning for Coders . Everything seems to be working except the jupyter notebook. When I try to run jupyter notebook by using the command: $ jupyter notebook, as the instructions state, I get the following error:

Command 'jupyter' not found, but can be installed with:

sudo apt install jupyter-core

```. I read the forums and I saw couple of people who had the same problem. I tried following the suggested steps but the issue is still present. Any help would be appreciated.

Can you run:

pip install jupyter


yes, I can. The issue is still present after runing pip install jupyter.

The terminal suggest sudo apt install jupyter-core but when I run that and run jupyter notebook afterwards, I get:

  File "/usr/bin/jupyter", line 11, in <module>
    load_entry_point('jupyter-core==4.6.3', 'console_scripts', 'jupyter')()
  File "/usr/lib/python3/dist-packages/jupyter_core/", line 247, in main
    command = _jupyter_abspath(subcommand)
  File "/usr/lib/python3/dist-packages/jupyter_core/", line 133, in _jupyter_abspath
    raise Exception(
Exception: Jupyter command `jupyter-notebook` not found. ```

I found this help page googling the error:

When I started the server today, I cd fastbook folder and run jupyter notebook command in that folder and the jupyter notebook was up running! So all I needed to do to solve this issue after pip install jupyter and sudo apt install jupyter-core was restarting the server? Thank you Jan for taking the time and helping me. It really means a lot to me.

1 Like

So glad you found a solution. All I did was provide some links…

Good job!