-bash: pip: command not found

I am trying to get started here by downloading all of the necessary software for the program, however, I am running into a relatively easy hiccup right off the start, which is that Cygwin is telling me there is no such pip command in its library.

Any help is greatly appreciated!

Thank you.

take a look at this:

Although you could just install pip on windows along with all the dependencies.


Thank you for the help! The link you provided along with: https://serverfault.com/questions/7282/how-to-run-easy-install-in-cygwin helped me figure it out!

1 Like

Do you remember how did you resolve this? I am having the same problem and have tried all above nothing works


Hey @susanli! So basically you need to install ez_setup onto your computer. The easiest way to do it is following this reccomendation from stackexchange:

Open up your cygwin prompt and type the following:

$ wget http://peak.telecommunity.com/dist/ez_setup.py
$ python ez_setup.py

That should install ez_setup and then running pip should be possible!

1 Like

Thanks for your quick reply, after the above 2 lines I got this:
-bash: python: command not found

So I have to find out why “python command not found”

Thank you for your help, now it works like a dream

When I tried to run pip on mac os x, I got: command not found.

I was running python3, but not anaconda. I did install anaconda 2.7 for mac and python --version says:
Python 2.7.10

Any help would be greatly appreciated!

On a more recent anaconda and cygwin install, pip was installed as “pip2.7”


1 Like

Yes! All the quirky errors i had in the terminal are gone!

Not sure what changed but pip install awscli worked, even though I did not use ez_setup.py
I just tried it again…

I have the same problem “python command not found”.
Do you remember how did you resolve this?

For me, it was because my Cygwin did not include python, I downloaded again, then it worked.

Hi, same problem as the top post. I have installed Anaconda3 before Cygwin. From the above discussion, am I right to say that I will need to reinstall Cygwin with the Python package provided there? Are there any alternatives? Can I change the Cygwin config file to manually add a path leading to my python.exe? Thank you!

easy_install-3.6 pip

Downloaded python or cygwin again? I’ve first installed python using Anaconda and then installed Cygwin as per lecture

I got it.


$ wget http://peak.telecommunity.com/dist/ez_setup.py
$ python ez_setup.py

If you have “python command not found” issue:
rerun cygwin installer and in the setup window view ‘Full’ and in the Search window type ‘python2-setuptools’

Now you’ve python

So, run:

$ easy_install-2.7 pip


Thanks guys, it worked like a charm :slight_smile:

Worked for me (Windows 10), thanks.
However: On my first attempt I got an error from easy_install-2.7 saying that I do not have the right permissions to change the /lib/python2.7 path. This was true as I installed cygwin with another account with administrative rights.

I fixed this with deleting cygwin again an reinstalling it only for my working account (without admin rights) by starting

 `setup-x86_64.exe --no-admin`

from the command line. Then it worked.