AWS AMI available for testing

For folks who are confident in getting around AWS and Linux, please test out this AMI I just created - name is fastai-part1v2-p2, id is ami-8c4288f4, region is Oregon. NB: this only works with P2 instances.

The repo is in ~/fastai, and all libs and the dogscats data are installed and ready to go. So you should be able to run lesson one without changes - although I’d suggest doing a git pull first.

Any feedback or comments welcomed!


@jeremy Thank you very much ! Is there any way to test it in another region ?

@jeremy I was able to create a p2 instance and ssh into it using this new AMI.
I’m not able to run a jupyter notebook however. Don’t know what’s going wrong.

For the instance, I just typed: jupyter notebook

In my browser, when I do: <my-elastic-ip>:8888/?token=.... , it just displays a message Refused to connect.

Did you try tunneling?

Also you may need to configure jupyter notebook.

Configuring jupyter notebook

jupyter notebook --generate-config

To create a password run

#jupyter notebook password
echo “c.NotebookApp.ip = '*'
c.NotebookApp.open_browser = False” >> $HOME/.jupyter/


@jeremy Is it possible to put this new AMI to the region of Ohio as well? Not able to try due to gpu limits in Oregon. Thanks

1 Like

Jupyter notebook works fine with this new AMI, ami-5f2fe427. Did you do tunneling when you ssh to the instance? If not, you need to. The command:

$ ssh -i <path_to_your_.ssh>/<your_key_file.pem> ubuntu@<your_instance_ip> -L 8888:

1 Like

Interesting. I did do the ssh tunneling. I’ll try that setup again. Thanks!

For AWS ami-5f2fe427, lesson1.ipynb, the following needs update. The data is there, just needs to point the path to it, do:

PATH = “/home/ubuntu/data/dogscats/”

no need for:

Extra steps if NOT using Crestle (e.g. if you’re using AWS …)
The dataset is available at You can download it directly on your server by running the following line in your terminal. wget You should put the data in a subdirectory of this notebook’s directory, called data/

It’s already pointing at it - there’s a data symlink in the spot PATH points to, I believe.

I am using PuTTY. Launching Jupyter Notebook also worked fine. The path to the data needed no modification.

Here are some results from testing the new AMI.

Try rebooting your instance.

I am still having the same issue after a reboot. Then I stopped / restarted and still having the issue.

Try git pull?

I tried and there are some unmerged files. I will work on this and get back to you sometime on Friday (US date).

Worked great for me!

Mild hiccup: environment.yml in the repo was modified, so I had to

cd fastai
git checkout -- environment.yml
git pull

to update the repo.

Maybe this is affecting @bdekoven?


Can we follow instructions from V1 to try it?

Works well. Didn’t have to git pull. Thanks!

yes @claytonjy , I had this issue with environment.yml

After fixing “git pull” indicated already up to date. But still have runtime error

What kind of AWS instance did you choose? I chose p2.xlarge; I think any p2.* should work. Did you choose a non-GPU instance? Could explain the error coming from CUDA.

Yeah good point - anything other than p2 won’t work.