Anyone Having Issues With Getting CUDA Running on a P2 Instance

So I had provisioned an EC2 instance for the earlier version of Lesson 1 using Theano and everything worked fine. I cloned the fastai/fastai repo on the same machine and followed all the instructions and ran the notebook. And got False when the notebook ran torch.cuda.is_available()

In the python console I tried running the same function got back True. So Im not entirely sure whats going on here. Is this a PyTorch install issue?

problem solved. It was an issue with the version of CUDA I was running. Im guessing the FastAI env required CUDA 9 and I was running 8. I looked into the nvidia docs and here were the steps i followed
Get the link address to the pkg based on your system architecture

wget link-to-pkg
sudo dpkg -i cuda-repo-ubuntu1604_9.1.85-1_amd64.deb
sudo apt-key adv --fetch-keys
sudo apt-get update
sudo apt-get install cuda

1 Like

great work. Worked for me. Cheers

Google Cloud Compute (where iā€™m running my VM) seems to install CUDA 7.5 by default. So any other google users, with this error, this is a valid fix.