Anyone able to run the Lesson 1 notebook?

Just checking if anyone is actually able to run the Lesson 1 notebook. I get a lot of errors trying to run it on Crestle

I used AWS, and it works fine there after setting up the environment. What errors are you seeing?

Exception in thread Thread-15:
Traceback (most recent call last):
File “/usr/lib/python3.6/”, line 916, in _bootstrap_inner
File “/usr/local/lib/python3.6/dist-packages/tqdm/”, line 144, in run
for instance in self.tqdm_cls._instances:
File “/usr/lib/python3.6/”, line 60, in iter
for itemref in
RuntimeError: Set changed size during iteration

I get this after running the cell with ->, 3, cycle_len=1)

I also used AWS. An EBS volume with p2.xlarge spot instance and Amazon Ubuntu DL AMI.

Steps I had to do:

  • Amazon DL AMI came with python 3.5 and fastai needed 3.6 so installed Anaconda on the EBS volume
  • Had to install a number of python modules - ones I recall are -
    sudo pip3 install bcolz
    sudo pip3 install toolz
    sudo pip3 install isoweek
    sudo pip3 install pandas_summary
    sudo pip3 install tqdm

After that it worked fine.


Hi Sanjeev,

I also encountered the same steps with python modules and now need to install python3.6 on the EBS volume.

Can you share how you installed on the EBS volume?


I already had an EBS vol I have used in the past that had Anaconda python 3.5. So i upgraded that to 3.6.

But you just have to install Anaconda3 from scratch. This should have info -

If you get stuck let me know.

Note that it is important that if you are using spot instances to install this on EBS volume which will survive after you terminate the spot instance.


The installation worked and now I see “Anaconda” folder. But only looks like python3.5 is there?

@atreides make sure you git pull, then restart your notebook. I’ve never seen that error before, FYI, and I’ve run this lesson from scratch on 2 different crestle instances.

1 Like

@sanjeev.b oops, my mistake. It is there. Thank you, Ben

Now i try to run lesson notebook on the Amazon DL AMI i encounter “Dead kernel” and restart fails after many attempts.

Check your Linux terminal - you should see the error message there.

Looks like module ipykernel_launcher is not there

Most likely your issue is that you have installed Anaconda3 with python 3.6 but when you are running python it is going to standard python on the box. So do which python to verify you are running right python. If not you have to do “source path-to-your-anaconda-python-bin/activate” and then run jupyter from that terminal

I think I am running python3.6.3


In the previous image the path it is showing is /home/ubuntu/anaconda/bin/python whereas in this last image you have path as /usr/bin/python

So seems as if you have two diff python versions and the jupyter is not running in the right env.

If that is not the case (e.g. one is a symbolic link to another) then see if this helps -!topic/anaconda/6OkNtiJmq0A

trying to import the fastai module, but that’s the error I get. The python version is correct at 3.6 and I did a git pull to get the repo onto my AWS instance.

What directory should I be in to run jupyter notebook? I’ve activated Anaconda 5.0.1 and am running jupyter notebook at /home/ubuntu/fastai

You need to install opencv. There are other messages in this forum that explain how to fix it.

Note that the little magnifying glass in the top right is a ‘search’ button. If you search for ‘cv2’ you’ll find the solutions that @sanjeev.b is referring to.

I am still having issue getting past ‘cv2’ module issue. And I think there is also issue with the path. Suggestions would be appreciated. Thank you, Ben

Hi Jeremy. Thanks again and again for the course.

I was reading the lesson 1 notebook and I keep getting these errors:
from fastai.torch_imports import *
Traceback (most recent call last):
File “”, line 1, in
File “fastai/”, line 24
if pre: load_model(m, f’wgts/{fn}.pth’)
i cloned the repo from fastai Github account.
any fix?