Anaconda3 and virtualenv

I’ve looked all over and cannot find a good fix for my issue (posted also on stackoverflow:

Basically, I was happily using anaconda3 for awhile and then a side project I did required virtualenv. i installed that and it worked fine. But now, when I try to activate any one of my conda environments with “source activate” or even “source anaconda3/bin/activate {conda env}” it only activates my virtualenv environments. I’d like to be able to use both anaconda and virtualenv and not have to do any re-installation if possible. (and if not possible i’d be more willing to uninstall virtualenv and then reinstall it put in a manner that doesn’t break my existing anaconda set up, as I have a bunch of conda environments already).

Any help on this would be much appreciated! Thanks and let me know if I need to provide more info

The way I work around this is that I use ONLY virtualenvs. I just have different ones which I use for different projects or testing new libraries. I never install new libraries to my production env.
Because I am lazy to type a lot I made an alias in ~/.bach_aliases for each virtualenv. This way I can easily invoke each env by typing a single short word.

1 Like

Thanks for the response! Might try looking into that - but I would really rather be able to use both as I really do like using Anaconda. Still hunting and if I find a solution will post back here

May be you can use Anaconda Navigator and launch from there or conda config --set core.default_env=root You may check the docs for details.

1 Like

Tried to launch via navigator but it still launches the virtualenv environment. currently trying to get the other command to work but as is i get an error of saying --set: expected 2 arguments. Doesn’t work if I replace the equals with a space either.

Thanks again