404 Not found when downloading planet dataset on Colab

I am using Google Colab for lesson 3 (lesson3-planet.ipynb).

I have mounted my google drive like so:
from google.colab import drive

Then I have created a .kaggle folder and uploaded my API key, and set it to the env variable:

import os
dest = “/content/drive/My Drive/Colab_Notebooks/FastAI/.kaggle/”
path = Path(dest)
path.mkdir(parents=True, exist_ok=True)
os.environ[‘KAGGLE_CONFIG_DIR’] = dest # put path for

datapath = Path("/content/drive/My Drive/Colab_Notebooks/FastAI/data")
path = datapath/‘planet’
path.mkdir(parents=True, exist_ok=True)

However, when I run the following line, I am presented with the error message ‘404 - Not Found’

! kaggle competitions download -c planet-understanding-the-amazon-from-space -f train-jpg.tar.7z -p

Any ideas as to why this is? Other kaggle commans (such as !kaggle competitions list) seem to work?

1 Like

I think the files are gone?

!kaggle competitions files planet-understanding-the-amazon-from-space
train_v2.csv/train_v2.csv 1MB 2019-12-15 22:14:13
test_v2_file_mapping.csv/test_v2_file_mapping.csv 600KB 2019-12-15 22:14:13
sample_submission_v2.csv/sample_submission_v2.csv 3MB 2019-12-15 22:14:13
Kaggle-planet-train-tif.torrent 1MB 2019-12-15 22:14:13
Kaggle-planet-test-tif.torrent 2MB 2019-12-15 22:14:13

1 Like

I am also having this issue - I resolved my 403 error, only to get a 404.

The files are still on the site - they can be downloaded manually and uploaded to the notebook.

You’re right Peter. The files are gone. As @sebbenbear mentioned, you can still download manually from Kaggle but the file size is not small (~600 MB for the training dataset).

Someone had similar issue 2 weeks before, did you try this?

yes. It didn’t help.

Thanks for the replies guys.
I ended up downloading it manually off kaggle, then uploaded it to google drive (and unzipped it on there I think) :

from google.colab import drive
datapath = Path("/content/drive/My Drive/Colab_Notebooks/FastAI/data")
path = datapath/‘planet’
path.mkdir(parents=True, exist_ok=True)

[PosixPath(’/content/drive/My Drive/Colab_Notebooks/FastAI/data/planet/train_v2.csv’),
PosixPath(’/content/drive/My Drive/Colab_Notebooks/FastAI/data/planet/train-jpg.tar.7z’),
PosixPath(’/content/drive/My Drive/Colab_Notebooks/FastAI/data/planet/train-jpg’)]

There are now torrent files on the Kaggle. How can I download dataset though torrent files in Colab.


I have the same problem. Please help.

I have the same issue. Kaggle only has two torrent files now it seems. I tried to manually download the training set using the torrent Kaggle-planet-train-tif.torrent but got stuck after a while. It shows the data is 13.82GB btw. Any other solutions for now?

Have you searched the forum that “someone” uploaded the train dataset image on google drive for you?

So you can just save it to your google drive and copy the image to your notebook through colab??

OK I got the manual download working, just had to click on that file no need for the torrent. Thanks for the reply anyway