Setup problems: AWS


(Zarak) #535

Hi @nvavryk,

Have you tried the solution here?


(Nazariy Vavryk) #536

Hi @z0k, thanks for replying!

ahh, I should be more careful. Should have noticed that that question was raised. Let me try. QQ, would I need to run the setup_instance shell script before the setup_p2? Since the tutorial video says that ec2 with p2 can be now created directly in the form (I am not sure what was meant by “directly in the form”). Thanks!


(Zarak) #537

Once you get aws working in Cygwin, you can simply run the setup_p2.sh script - it will execute the setup_instance.sh script for you. :slight_smile:


(Nazariy Vavryk) #538

Thanks :slight_smile: Strange my cygwin freezes when I attempt to uninstall awscli on this step:


(david meisenzahl) #539

I think i got one step closer, did the wget that you recommended, thank you.

wget https://github.com/fastai/courses/blob/master/setup/setup_instance.sh
–2017-04-30 10:02:58-- https://github.com/fastai/courses/blob/master/setup/setup_instance.sh
Resolving github.com… 192.30.255.112, 192.30.255.113
Connecting to github.com|192.30.255.112|:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: unspecified [text/html]
Saving to: ‘setup_instance.sh.1’

setup_instance.sh.1 [ <=> ] 72.05K 452KB/s in 0.2s

2017-04-30 10:02:59 (452 KB/s) - ‘setup_instance.sh.1’ saved [73784]

get https://raw.githubusercontent.com/fastai/courses/master/setup/setup_p2.sh
–2017-04-30 12:31:26-- https://raw.githubusercontent.com/fastai/courses/master/setup/setup_p2.sh
Resolving raw.githubusercontent.com… 151.101.24.133
Connecting to raw.githubusercontent.com|151.101.24.133|:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 528 [text/plain]
Saving to: ‘setup_p2.sh.4’

setup_p2.sh.4 100%[=========================================================================>] 528 --.-KB/s in 0s

2017-04-30 12:31:26 (62.9 MB/s) - ‘setup_p2.sh.4’ saved [528/528]

After the wget actions, I attempted the two bash executes:

bash setup_instance.sh.2
! {i’ve done this more than once}

Missing $ami or $instanceType; this script should be called from
setup_t2.sh or setup_p2.sh!

bash setup_p2.sh.4
! {i’ve done this more than once}

./setup_instance.sh: line 7: syntax error near unexpected token newline' ./setup_instance.sh: line 7:

Interesting, same error when did setup_p2.sh.4. Could I have the wrong version of bash or some other out of version issue?


(Zarak) #541

Try deleting all the setup files and getting fresh ones - the setup_p2.sh script is going to expect that the other script it invokes is named setup_instance.sh.


(Nazariy Vavryk) #542

that resolved it thanks!


(Nazariy Vavryk) #543

I have seen that the tutorial talks about selecting eu-west-1 if I am based in Europe (I am based in London), but I got an email today from aws when I registered saying that just for EC2 I cannot use that, and should go with the us-west-2, is that fine? :slight_smile: Thanks


(Zarak) #544

That’s strange. I am currently using eu-west-1 (Ireland). Did they say why you can’t use it?
To answer your question, us-west-2 should work fine.


(david meisenzahl) #545

Yes, I completely overlooked I was call the outdated version of setup_instance.sh. Thank you. Now I have to wait for Amazon to complete Limit Increase: EC2 Instances request.

I ran setup_p2.sh before Amazon completed my request, the following was the result:

True

An error occurred (InstanceLimitExceeded) when calling the RunInstances operation: You have requested more instances (1) than your current instance limit of 0 allows for the specified instance type. Please visit http://aws.amazon.com/contact-us/ec2-request to request an adjustment to this limit.

An error occurred (MissingParameter) when calling the CreateTags operation: The request must contain the parameter resourceIdSet
Waiting for instance start…


(Nazariy Vavryk) #546

Hi, does one have to request an instance in aws console in addition to running the setup_p2.sh?


(Nazariy Vavryk) #547

This is what they said:

As a new customer, you can launch Elastic Compute Cloud (EC2) instances in 3 AWS regions. We suggest you to use the regions US East (Northern Virginia), US East (Ohio), US West (Oregon), but if you prefer other regions please contact us at aws-verification@amazon.com and let us know which 3 regions are more convenient for you. You can find the list of regions and which services are available in each of the regions at http://aws.amazon.com/about-aws/globalinfrastructure/regional-product-services/. Please make sure you are not running EC2 instances in the region you are transitioning from.

OK, I guess they do not exactly say that, but nevertheless, they say that (i.e. that I cannot use eu-west-1) if I want to use another region, I have to contact them.


(Jake) #548

Thank you, this worked, @z0k! And thanks @Rothrock42 for your help as well.


(Sahil KARKHANIS) #549

Hi David,

Can you please write the steps that you did for solving the error!
from where did you clear the setup files suggested by Zarak?
Because as Zarak had suggested using raw, its still taking the entire HTML page for me.

Please write down the steps you did for running the script, also from where did you clear the setup file.


(Nazariy Vavryk) #550

Hi,

Do I have to request instance limit increase for t2 as well? (I thought it was free)


(Nazariy Vavryk) #551

I requested t2.large, in addition to p2.large


(david meisenzahl) #552

To recap, from the command line, i ran

rm setup*.*

this deleted all my old downloads from a different location.

then i used the links from the course GitHub

wget https://raw.githubusercontent.com/fastai/courses/master/setup/setup_instance.sh

wget https://raw.githubusercontent.com/fastai/courses/master/setup/setup_p2.sh

then i did the next command

bash setup_p2.sh


(Sahil KARKHANIS) #553

Thank you soo much @ozora999 and @z0k, i have successfully implemented the setup. See you all in the course. :slight_smile:


(Zarak) #554

I didn’t had to make a request for a t2 instance. Perhaps AWS has changed some of the restrictions for new accounts. I’m not really sure.


(jvr605@gmail.com) #555

$ bash setup_p2.sh
Only us-west-2 (Oregon), eu-west-1 (Ireland), and us-east-1 (Virginia) are currently supported

I am facing that error while trying to setup an instance.

can someone help me resolve it?