Paperspace setup help


(Deepak) #144

Promo code for 10$ https://www.paperspace.com/&R=29QXDII


(Ibrahim Khalil) #145

Try a different card. In my case, it worked with MasterCard but didn’t work with visa


(Jeremy Howard) #146

Thanks to @dillon and team there’s now an updated fast.ai template we can use, which means you don’t have to set up your instance from scratch! I’ve updated the top post with the following:

The video shows how to set up paperspace from scratch, but that’s no longer necessary - instead, choose the ‘fast.ai’ paperspace template (instead of the ubuntu template) when you create your instance.

(No need to re-create your instance if it’s already working - paperspace have simply run the script I provided to create this template, so it should be identical to what you already have.)

@reshama - is there any chance you could update your terrific setup page with this new info?


Deep Learning Brasília - Lição 1
Deep Learning Brasília - Lição 1
(Reshama Shaikh) #147

@jeremy
updated Paperspace instructions to use fastami template :white_check_mark:

Super news!


(Reshama Shaikh) #148

thanks @dkobran
I’ve added the link to the Paperspace instructions.


(Daniel) #149

@reshama Thanks for doing that.

One thing I wanted to clarify is that under Step 6 it mentions that you pay for storage each time. Fortunately, that is not the case. If you deactivate a machine, a corresponding amount of credit is added so you actually only pay for the amount of time the storage was used (it’s prorated like compute).

This is definitely confusing and we’ll be moving storage to the end of the month soon to make it more clear. The good thing is, you can create/destroy machines all day and you will only get charged while the storage is active (to the millisecond!). Apologies for the confusion!


(Reshama Shaikh) #150

@dkobran
That’s good to hear! (as I set up my machine 3 times, so that would have instantly used up $15 right there).
I’ve updated the text to:

storage costs are pro-rated (like compute (or “usage”) costs)


(Jeremy Howard) #151

That is great news!


(Himalayas) #152

Here’s another referral code. Machine recreated. NV1X8GG


(Suvro Banerjee) #153

I am trying to setup paperspace, and have been able to launch the Jupyter Notebook. But for some reason the page is coming as blank in the browser. However, I could see in the paperspce cli that the Jupyter notebook is getting launched.
I am using Mac and facing the same issue both on Safari and Chrome. Has anyone faced this issue or know the resolution. Thanks a lot. Can’t wait to fix it asap and start the course :slight_smile:

Thanks
Suvro


(Suvro Banerjee) #154

Created my machine on my personal windows PC, excited to get started. Here is a referral code, if anyone is interested to get extra Paperspace credit. Have a good one.

Send $10 to a friend and earn $15 in account credit!

Share your referral code:
I0NBII5


(Vikas Bahirwani) #155

Thank you very much @Ralph, this is encouraging :smiley: . I appreciate your detailed response.


#156

What do these 3 command phrases do?
echo 'export PATH=~/anaconda3/bin:$PATH' >> ~/.bashrc
export PATH=~/anaconda3/bin:$PATH
source ~/.bashrc


(Chandra Sutrisno Tjhong) #157

Hi,

I am unable to use paperspace server, they rejected my credit card because I am come from outside US. If I use Amazon, can I still follow all the walkthrough on the video or this courses exclusively to used in paperspace server?


(Jeremy Howard) #158

We support AWS too.


(Sandip) #159

For 6 days I spent most of the time on paperspace waiting for it to start up; finally cancelled the account today. I was able to load the fast ai library and look at the notebooks. Couldn’t get around to load new data. I am in CA. Is my experience unique? Trying to decide if I should give it another try or go back to aws?


(Jeremy Howard) #160

I haven’t experienced that myself. You may want to contact their support, or ask @dillon here who is from Paperspace.


#161

@sandip @jeremy I am having the same problem with Paperspace not loading. I set up a server last night and used it for ~30 minutes and it worked great. Shut it down and have tried to use it again but it won’t start. The little circle on the start button just spins forever. I’ve submitted a ticket with support so we’ll see what happens.

I have a Hackintosh with a GTX 1080, so maybe it’ll be best to install a new drive with Ubuntu and dual boot and access the machine through my laptop. Was hoping Paperspace would make it even easier than that for now.

Edit: I did get it to load eventually. Not sure what changed.


(Sandip) #162

@kmbutler, @jeremy

Earlier in this thread there is some mention of the paperspace terminal being bugg-y.
So I have been trying using ssh for the last hour.
My experience so far is that ssh works if the paperspace machine is in the ‘ready’ state at the website.
I was able to change my unix pwd, install fast ai and the start the notebooks.
No success with using scp to transfer image data from my local machine to paperspace yet :slight_smile: but thats just my learning curve.

One curious observation (cannot claim causality yet): the paperspace terminal worked like a charm while bay area was commuting this morning.


(Abhishek Sharma) #163

My jupyter_notebook_config.py contains these two lines. Still My Jupyter notebook is not launching on ubuntu.