Paperspace setup help


(Alex) #164

Hi all. I really don’t have much experience with all this, but sorta stumbled my way into a temporary fix which could lead to a “proper” solution for this. My fix was as follows:

ssh into your paperspace instance, while forwarding a port:

ssh paperspace@YOUR_PUBLIC_IP_ADDRESS_ADDRESS -L 8889:127.0.0.1:8889

I used port 8889 instead of 8888 because 8888 was giving me some sort of error. Maybe 8888 will work for you. My understanding is that this command ssh’s into your instance as usual, but additionally forwards port 8889 to your ‘localhost’.

Next, I started a notebook on port 8889:

cd fastai/
jupyter notebook --port=8889

Finally, I could now access the notebook by entering the following in my browser:

localhost:8889

The password is ‘dl_course’

Hope this works for others as well!


(Jeremy Howard) #165

If you’re not able to access your Paperspace jupyter notebook, try this:

sudo ufw allow 8888:8898/tcp

It opens the firewall to allow jupyter notebook connections. It ought to be there by default, but it sounds like some might be missing it. @alknemeyer let me know if this removes the need for ssh forwarding for you.


(Alex) #166

The response to running that command is:

Skipping adding existing rule
Skipping adding existing rule (v6)

Unfortunately things are still otherwise the same (ie I need port forwarding and “cannot listen to port: 8888”). I started this machine today using the premade paperspace template


(Jeremy Howard) #167

OK then my guess is the firewall is at your end. ssh forwarding is the best solution in that case :slight_smile:


(Sandip) #168

Confirming that ssh into paperspace is still working today, with the vm in the ready state at the website while logging into the terminal at the website does not work (gives a broken pipe error).

I have also figured out how to use the scp command correctly :slight_smile:


(Jeff) #169

If anyone needs a paperspace referral code: 5UBEU1J


(Chandra Sutrisno Tjhong) #170

Hi all,

I tried to buy server from paperspace but they rejected my credit card and I think all credit cards from my country. Is there anyone know how to setup this course on Amazon?

Please advise


(Chandra Sutrisno Tjhong) #171

Hi Jeremy,

How to setup this course (the second version) on Amazon?

Please advise


(Stephen Wood) #172

Was getting this error also for UK credit card. I switched from a Visa card to a Mastercard and followed the same work around as for Canadian postal code (take the numeric values and pad to five digits with zeros). This seemed to work.


(TRIDIB DUTTA) #173

How do we move files between paperspace and my local computer ?


(Nick) #174

Not unique. I’m having the same experience. My guess is that they aren’t used to the volume that their getting from fast.ai.


(Nick) #175

(nok) #176

Echo means print basically, it prints ‘export PATH=~/anaconda3/bin:$PATH’ to .bashrc which is the default environment when you start using bash command. So next time when you start a new terminal, it will automatically run this command.

The second line is actually calling “export PATH=~/anaconda3/bin:$PATH” because otherwise you need to restart your BASH command as .bashrc is applied when you start a new terminal.

The third line means apply the things that in .bashrc


(Sandip) #177

@NickM, @tdutta

Nick, I have been able to use paperspace productively, using ssh after turning the machine to the ready state on the website. Hope you are being able to use it too? Else, please ask specifics.

Tridib, scp stands for secure copy; working from your source (commonly abbreviated as src) directory, you will need to tell it what the destination computer is, so the computer’s name at an ip address, which turns out to be paperspace@your paperspace public ip
this is how the command looks like: scp -r /my/path/to/the/directory/to/be/copied paperspace@my ip:/home/paperspace/data
You can do a pwd (print working directory) on the paperspace terminal to figure out the path you need for the destination(often abbreviated at dst in linux or ubuntu forums).
The -r tells the command to recursively copy all folders and subfolders and everything in them.
Also, I first learnt to use scp to transfer folders from one directory to another in my local machine, then from my local machine to paperspace and finally from my SD card to paperspace.
I found this helpful: https://unix.stackexchange.com/questions/188285/how-to-copy-a-file-from-a-remote-server-to-a-local-machine


#178

I’ve been able to use paperspace successfully, there are some glitches when using desktop viewer in Chrome (when i type, it doesn’t type into the machine).

Here is a promocode to get $10 off: O5Q1LC6


(TRIDIB DUTTA) #179

@sandip. Thanks much. Suggestion is helpful. If I am using a mac osx, I believe I can use SSH. Right? Thanks again.


(Sandip) #180

look at video, lesson2 end and lesson3 beginning…


(Travis Dickey) #181

I had the same problem, but it seems not to be an issue if I click the settings icon (upper right of image below) and go in from the screen the pops up.

paperspace-4

However, every time I tried to lauch directly from this screen, it would just spin and spin.


(Sandip) #182

Being able to do the work on paperspace from my chromebook w/ Ubuntu is a huge step in the right direction, compared to last year.

I use jupyter notebook from my local machine for learning /testing out codes and on the VM for the course related work. So using tmux is very helpful and accessing the vm through ssh is actually the preferred route for me.

Wrote all this to balance out comments regarding ‘problems’ + ‘paperspace’. Your workaround didn’t work on my system :slight_smile:


(Nikhil B ) #183

@dillon I’m re-doing some of the Part 1 assignments in Paperspace. This might have been asked before…

Does pricing change depending on how many times we choose to take a snapshot, and the number of snapshots we store? For eg. will snapshot pricing for 250GB remain $1.4 whether we choose to save it daily, weekly or monthly ?