Paperspace setup help


(Daniel) #124

@reshama This may be helpful for people connecting via SSH (which we can’t detect like the web-based terminal).


(Mac Yeh) #125

Hello,
Does anyone has the problem on opening the jupyter from the web browser?
But when i check terminal, it clearly said the jupyter network is running.
Anyone has the potential solution? Appreicate if someone can help us. Thanks
image


(Mac Yeh) #126

@radi
Did you solve the issue? I think I have the same problem as yours, could not open notebook in the browser. Appreciate anyhelp


(Sasikanth) #127

Thanks for the post…
Referral code: N2N57J


#128

Vikas,

A GTX 970 with 4G memory should work for quite a bit of the course. Epochs will take longer, and you may need to reduce batch sizes so you don’t run out of memory. I would suggest using your local box for the majority of tasks and fire up paperspace, aws etc when the local can’t do the job.

I started working through the earlier course on a 750ti with 2G memory and was able to get through a lot. I have upgraded to a 1060 with 6G for more flexibility. I thought about the 1080ti with 11G, but I would have to upgrade the power supply as well so I am holding off until I can do a complete rebuild. Even Jeremy had to limit his batch size on one of these models to fit into 11G, so there is always going to be a desire for more :wink:


(Tom Brown) #129

@mac0428 I ran into this type of problem. My local computer is a Macintosh. I found this set suggestion in an early note in this thread.

After a bit of poking around, I was able to get this to work. Note this is not the method shown in the video which uses a token. You will have to login with a password using this method.


(Rui Guo) #130

Hi, cynosure. I use ubuntu 16.04, and what software package is the prerequisite for that script to run? Thanks!


(Rui Guo) #131

Hi, Ralph. I’m using a server with 2 k80, 64G ram, 12 Intel® Xeon® CPU E5-2620, and 128G disk. Can I use that to do all the work in the course? And what is the prerequisite package for the install script(just the paperspace one) to run? Thanks!


(Cynosure) #132

There is no other pre requisit. Just run this script on ubuntu.

I ran it line by line rather at once.


(Navid) #133

Hi Jeremy
I have the issue to setup paperspace script “curl http://files.fast.ai/setup/paperspace2 | bash” command in my local computer with os ubuntu 16., not paperspace cloud. Actually, in apt.conf.d, I do not have any files like . with extension to delete. the error comes up as follows:
"rm: cannot remove ‘/etc/apt/apt.conf.d/.’: No such file or directory"
In this case, this command maybe has to be skipped!
If I am right, please confirm.
Thanks


(Mac Yeh) #134

@tgb417
Thanks for the help. I know the problem is coming from the certain firewall will block the suspicious IP. Unfortunately the IP Paperspace provide is in that category. I change the network environment and jupyter is working now. The suggestion now is not to use the network environment which will block your IP. Hope it will be helpful for future learners.


#135

Rui

Your server should be more than enough, though if you are sharing the server with others who are also working it hard, you may need to coordinate with them. I don’t think pytorch does multi-gpu on a single model, but another user might be using tensorflow and hogging both gpus.

If you are on your own server rather than paperspace:
git clone https://github.com/fastai/fastai.git
cd fastai
conda env update
source activate fastai
jupyter notebook
use the url given in the terminal if jupyter doesn’t automatically pop up in your browser

–edit - I see up top that Jeremy says the paperspace script should work for any ubuntu computer, so I guess try that first


(Purshottam) #136

please add my PROMO CODE for extra 10$ = NPUIS5C


(Reshama Shaikh) #137

Paperspace instructions have been updated with a couple of perks:
-You can now set it up so that you don’t have to

  • enter your password each time you ssh into Paperspace from your local computer
  • can click directly on Jupyter notebook token link without having to add in your IP address to your browser link

“Optional Steps” have been added to the end of the paperspace.md file


#138

Promo code for 10$ https://www.paperspace.com/&R=3KM29VE


#139

Promo code for $10 - https://www.paperspace.com/&R=3WWI5MW

Can be stacked with FASTAI promo. See this post: Paperspace setup help


(Martin Hall) #140

I’m getting the same error using a UK post code. Removing the space doesn’t solve the problem for me. I’ve reported the problem to Paperspace.


(David Yeah) #141

Is there an easy way to switch between only cpu and gpu with paperspace?
because when you just trying something in the notebook and debugging you dont really need a gpu.
with crestle you simply switched that button, so you could try some things with you code very cheaply and than run it with the gpu. however with paperspace you seem to be stuck with the gpu. any ideas?

Anyways, if somenbody needs a promo code.
https://www.paperspace.com/&R=7QIX6RI


(Seema Goel) #142

Anyone looking for promo code for Paperspace setup n $10 credit use AN803CR


(Martin Hall) #143

My problem was resolved by using a different debit card. It didn’t like Monzo.