Paperspace setup help


(Nikhil B ) #184

Trying it out on a Mac first time, looks like this is a good solution. Looks like tunneling was required. I was able to use the normal ports to start Jupiter i.e.
ssh -L 8888:127.0.0.1:8888 paperspace@xxx.xx.xx.xx


(Ksenia) #185

Hello, everyone, I am a nubest nube possible.

My personal OS: Linux Ubuntu 17.10
My personal browser: Firefox (latest)

I work on trying to set up an initial fast.ai environment on a new paperspace machine. So I am working in a browser console on paperspace, right?

Entering “curl http://files.fast.ai/setup/paperspace | bash” does not work, because it sends me a mistake after “sudo rm /etc/apt/apt.conf.d/.” - something along the lines “rm: cannot remove file /etc/apt/apt.conf.d/. because no such file”.

Trying to copy command from the script one by one does not work because my clipboard does not copy the text to the browser console!

I found this https://paperspace.zendesk.com/hc/en-us/articles/236362428-Copy-and-Paste-Sync-Clipboard link with the helping suggestions, but I cannot find “small circle button in the Paperspace interface and then click “Sync Clipboard”” anywhere! No bashing of my head on the keyboard helped. Ctrl-V does not help, Winkey + V does not help, Shift+ins not working. I have a double booted Linux / Windows 10 laptop, and my default keys on Linux are kinda strange sometimes. I paste in Terminal with the mouse.

That’s how my interface of browser console looks like (no small circle buttons):

Please, help :frowning: or can you find me the script http://files.fast.ai/setup/paperspace with offending command hashed out? don’t want to drop fast.ai just because of stupid nube mistakes.


(Jeremy Howard) #186

Read the ‘important notes’ section on the lesson 1 page to learn how to do this much more simply: http://course.fast.ai/lessons/lesson1.html


#187

I had trouble registering my German Master Card. It kept failing the zip code validation for which I was trying to use my postcode (which funnily even has the same 5 digit format as US zip codes). Leaving it blank did not work either and neither Paperspace support nor my bank could help.
I the end I just tried it with na and it went through. Hope that helps others having similar problems. :slight_smile:


#189

I’m a newbie to this as well, and am wondering if anyone else is having my problems.
I have windows 10 and am connecting through chrome browser.
I never seem to be able to start my paperspace machine - just spins and spins and I keep going back to the console and trying to start it again.Really frustrating.
Then, when I get it started, it is impossible to open a jupyter notebook - I keep getting a note saying my computer is unable to connect. (Yes, I replaced local host with the location of my virtual machine).
I am really frustrated with this entire process. Shouldn’t it be easier to be part of your course? I spend hours watching things not connect or not able to connect. What am I doing wrong?
Sorry to be such a newbie…Hoping to learn something…


#190

Just followed the directions at https://github.com/reshamas/fastai_deeplearn_part1/blob/master/tools/paperspace.md for creating a Paperspace account. Waited for 15 minutes to receive an email stating that my server was finished provisioning. Then deleted that server and tried again, with same results, that is, server never finished provisioning. The UI now shows the status as inaccessible. Fun.


(Sam Shleifer) #191

I am on the fastai paperspace template and having trouble getting tensorflow to recognize/use the GPU. When I train stuff, nvidia-smi shows no usage, because tensorflow is using the CPU.

When I run

import tensorflow as tf

with tf.device('/gpu:0'):
    a = tf.constant([1.0, 2.0, 3.0, 4.0, 5.0, 6.0], shape=[2, 3], name='a')
    b = tf.constant([1.0, 2.0, 3.0, 4.0, 5.0, 6.0], shape=[3, 2], name='b')
    c = tf.matmul(a, b)
    print(c)

I get
Tensor("MatMul:0", shape=(2, 2), dtype=float32, device=/device:GPU:0)
all is good!

but when I run

from tensorflow.python.client import device_lib
device_lib.list_local_devices()

I get

[name: "/device:CPU:0"
device_type: "CPU"
memory_limit: 268435456
locality {
}
incarnation: 8013515368465626270
]

I googled a bunch and figured out that running

sudo ldconfig

and getting

/sbin/ldconfig.real: /usr/local/cuda-9.1/targets/x86_64-linux/lib/libcudnn.so.7 is not a symbolic link

is very bad news and may require reinstalling cuda stuff (which sounds awful), so I was wondering whether anybody else has run into this before venturing down that deep dark hole. I feel like I could just tell tensorflow to use the GPU without the decorator?

Thanks!


(Reshama Shaikh) #192

@dillon Can you help with this issue?


(Dillon) #193

Hi @bryonbean really sorry that the machine is stuck! That should really never happen and I know it is frustrating. Can you send an email to support@paperspace.com so we can get an engineer to look at it ASAP and credit your account back.


(Ankit Patro) #194

Hi Jeremy,
I am facing problem in selecting the fast.ai template.


Kindly provide insights.


(Greg Chwelos) #195

What’s not clear is if we use the template, do we do the “Part III Updating fastai repo contents” steps of reshamas script or not. I understand the template replaces the need for the “curl…” step, but do we do the Part III steps, or skip those? Thanks in advance!


(Jeremy Howard) #196

Yes you need to do that.


(Luke Harries) #198

I’ve setup the paperspace fast.ai template and performed git pull and conda env update but I’m still getting this error when trying to run the lesson 1 jupyter notebook. Anyone know how to fix this?

Traceback (most recent call last):

  File "/home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages/IPython/core/interactiveshell.py", line 2910, in run_code
    exec(code_obj, self.user_global_ns, self.user_ns)

  File "<ipython-input-3-b4501b23c5cb>", line 1, in <module>
    from fastai.transforms import *

  File "/home/paperspace/fastai/courses/dl1/fastai/transforms.py", line 2, in <module>
    from .layer_optimizer import *

  File "/home/paperspace/fastai/courses/dl1/fastai/layer_optimizer.py", line 2, in <module>
    from .torch_imports import *

  File "/home/paperspace/fastai/courses/dl1/fastai/torch_imports.py", line 19, in <module>
    from .models.nasnet import nasnetalarge

  File "/home/paperspace/fastai/courses/dl1/fastai/models/nasnet.py", line 620
    return model
                ^
SyntaxError: 'return' outside function

(Luke Harries) #199

try using the west coast region, that fixed it for me


(Francesco) #200

Hello everyone, I just finished setting up a machine in paperspace and I was making sure everything was working by executing the first lesson code in jupyter but I’m getting this and I don’t know what it is


Any idea?


(Luke Harries) #201

@teidenzero same with me, no idea how to fix it…


(Francesco) #202

@lukeharries I am trying to redo the curl http://files.fast.ai/setup/paperspace | bash but using sudo before the command, I’ll let you know how it goes


(Francesco) #203

@lukeharries no luck, hopefully somebody will help up


(Luke Harries) #204

@teidenzero I’ve tried Crestle which worked but it was so slow, even just importing the libraries, that it was not usable


(Francesco) #205

@lukeharries I’m trying to redo the process once again through ssh