Paperspace setup help


(Luke Harries) #206

for anyone else reading this: it has now been fixed. Perform ‘git pull’ in the /fastai folder to pull the fix


(Manishankar) #207

Here’s a referral code for $10 - 92GJX60
ATB!


(Ashwin Menon) #208

I’m getting the following error:

(fastai) paperspace@psjfhh3rl:~/fastai$ nvidia-smi dmon
Unable to determine the device handle for GPU 0000:00:05.0: Unable to communicate with GPU because it is insufficiently powered.
This may be because not all required external power cables are
attached, or the attached cables are not seated properly.

This happened after the latest git pull. torch.cuda.is_available() returns false. To figure out why, I ran nvidia-smi dmon as shown above. The error indicates no GPU?

I’m using Paperspace with the template AMI.

EDIT: for anyone who ran into this issue, I had to restart the machine.


#209

@jlrw, I had the same problem! Nothing could fix it, also looping in their support didn’t help, and I even couldn’t ssh into the machine.

This resolved it: I deleted the machine running form their Amsterdam center (I’m German), and set one up at the East Coast, after several attempts on the AMS data center failed. The East Coast machine works like a charm, so maybe give setting it up at another center a try!

Note: 1.) I used the ubuntu template - please see comments above: by now, the best option seems to be the fastai template
2.) If you delete a machine, the money paid for storage will only be charged as fraction of a month. So you will not be charged again for storage!

Hope that helps!


(Saurabh) #210

@dillon - I am using steps listed by @reshama on Fast.ai template. However, I am getting timed out error every time. I saw few posts on the forum but not sure of a solution. I am on window 7 OS and it’s my office machine. Could you please suggest how to get Jupyter up and running?


(ry101) #211

question:
I’m trying to choose fast.ai in papersace , but they say have to get back to me,
beacaue it’s unavilable in my account and I have to tell them why.

do I have to enter billing details ahead?


#212

Does anyone now how to change the color scheme on paperspace? The dark background color hurts my eyes and I can hardly make out the grey texts from the black background…


#213

You can connect to your Paperspace machine via SSH in Putty, there you can adjust the colour scheme of the console or use templates like the following:
https://www.igvita.com/2008/04/14/custom-putty-color-themes/


(Hakim) #214

I am currently having the same issue did your issue ever get resolved?


(Jorge) #215

I’m trying to choose fast.ai in papersace. I specify that I want to use fast.ai, but I do not receive an answer to be able to configure the machine. Can someone tell me what I should do?


(ry101) #216

Hi,

They approve within in a day.


(ry101) #217

Does anyone know what is the average billing in paperspace for a month for the course part 1?


#218

Good idea, thanks!


#219

Thank you so much for posting this fix! Every google search related to this issue led to the config file but none of the suggested edits actually fixed the problem. Your suggested config is the only one that worked for me. I think building the jupyter config file in the set up process might have helped avoid this issue.

For anyone using nano, paste in the edits, Ctrl-X exit, enter Yes when prompted to save.


#220

Any one looking for a promo code-

VIBNRQH :slight_smile:


(Jorge Barrios) #221

I had this issue due to the “vimium” extension, so I disabled it and it worked.


(Jorge Barrios) #222

Yes, just run this in your terminal:

ssh paperspace@myip


(Jairo) #223

Hi there guys,

My referral code is MHG4T8P


(Jithin James) #224

Here’s my referral code: MWZI1OR


(Sandip) #225

Try: watch jeremy’s video carefully and try to repeat every keystroke(in a manner of speaking)
Try: run jupyter notebook on your own computer to figure out how it works; I have Ubuntu+anaconda and do most of my code testing/learning/figuring out on my computer

I did not find any problems in the screenshot you have pasted…its working fine