Study Group in Bangalore (Koramanagala)

Hi Everyone,
Here are the meetup details. In case you folks have any questions, please feel free to reach out.

1 Like

Any live chat for the group?

We can use this thread for now. When we meet, we can plan some other mode if required.

1 Like

Please count me in aswell.

+1 Hi, all

Please register in the meetup link so we can have all the details, and make the necessary arrangements.


Hi, it’s not responding when i click the check mark button for attending. :white_check_mark:

Could be a temporary glitch. Do you want to try again?

I think,it’s because i am not a member. It says membership pending in the group description.

Hi Anubhav,

We are facing an issue in upgrading the meetup plan since we originally had a Basic subscription. We’re trying to sort it out soon and will get back to you. Meanwhile, please feel free to drop a note here if you are joining us this Saturday. Sorry about the inconvenience.

Thanks for the reply. Yes , i am willing to attend the meetup :slight_smile: .

Hi, why don’t we collaborate with other meetup groups?

Has anyone tried to run the lesson 1 notebook in google colab? I am getting error in the command learn.fit_one_cycle(4)

ERROR:root:Internal Python error in the inspect module.
Below is the traceback from this internal error.

Traceback (most recent call last):
File “/usr/local/lib/python3.6/dist-packages/IPython/core/”, line 2882, in run_code
exec(code_obj, self.user_global_ns, self.user_ns)
File “”, line 1, in
File “/usr/local/lib/python3.6/dist-packages/fastai/”, line 19, in fit_one_cycle, max_lr, wd=wd, callbacks=callbacks)
File “/usr/local/lib/python3.6/dist-packages/fastai/”, line 137, in fit
File “/usr/local/lib/python3.6/dist-packages/fastai/”, line 89, in fit
raise e
File “/usr/local/lib/python3.6/dist-packages/fastai/”, line 77, in fit
for xb,yb in progress_bar(data.train_dl, parent=pbar):
File “/usr/local/lib/python3.6/dist-packages/fastprogress/”, line 65, in iter
for i,o in enumerate(self._gen):
File “/usr/local/lib/python3.6/dist-packages/fastai/”, line 52, in iter
for b in self.dl: yield self.proc_batch(b)
File “/usr/local/lib/python3.6/dist-packages/torch/utils/data/”, line 637, in next
return self._process_next_batch(batch)
File “/usr/local/lib/python3.6/dist-packages/torch/utils/data/”, line 658, in _process_next_batch
raise batch.exc_type(batch.exc_msg)
RuntimeError: Traceback (most recent call last):
File “/usr/local/lib/python3.6/dist-packages/torch/utils/data/”, line 138, in _worker_loop
samples = collate_fn([dataset[i] for i in batch_indices])
File “/usr/local/lib/python3.6/dist-packages/fastai/”, line 91, in data_collate
File “/usr/local/lib/python3.6/dist-packages/torch/utils/data/”, line 232, in default_collate
return [default_collate(samples) for samples in transposed]
File “/usr/local/lib/python3.6/dist-packages/torch/utils/data/”, line 232, in
return [default_collate(samples) for samples in transposed]
File “/usr/local/lib/python3.6/dist-packages/torch/utils/data/”, line 207, in default_collate
storage = batch[0].storage()._new_shared(numel)
File “/usr/local/lib/python3.6/dist-packages/torch/”, line 120, in _new_shared
return cls._new_using_fd(size)
RuntimeError: unable to write to file </torch_217_2325047144>

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/usr/local/lib/python3.6/dist-packages/IPython/core/”, line 1823, in showtraceback
stb = value.render_traceback()
AttributeError: ‘RuntimeError’ object has no attribute ‘render_traceback

During handling of the above exception, another exception occurred:

are you still facing the error?

I have set the num_workers to 0 to fix this issue. This seems to be known issue with google colab.

data = ImageDataBunch.from_name_re(path_img, fnames, pat, ds_tfms=get_transforms(), size=224,num_workers=0)

Glad to know your issues has been resolved. A gentle reminder is that jeremy has provided colab support for fastai v3 here

This needs to be updated with the problem i have faced…

I am able to run code successfully multiple times. In fact I ran it just now.

donno what is causing…May be some version issue then…

Hello, I have just launched a discussion thread on fastai study groups to gather feedbacks from the organizers and participants in order to list the best practices and also to avoid some gaps.

More information in this post. Thank you if you have a few minutes to participate in the discussion :slight_smile: