Setup problems: AWS

(Safak Ozkan) #728

@ zeinab_sp You could delete the existing .ssh/aws-key-fast-ai.pem file. I would also delete it on Sign in to the console as the user (testuser). Then click “EC2”, and then “KeyPair”. If there’ are any KeyPairs that show up, right click and delete them.

Then, go back to your command line. and run bash It will create a new .ssh/aws-key-fast-ai.pem and also send it to AWS to store it under “testuser” account. Let me know

(Zeinab Sadeghipour) #729

@ozkansafak Thanks Safak, that solved my problem and my AWS instance is running now!


I managed to run it on Windows 10 and Cygwin, see here:

(blair) #734

Hey everyone,
Started this course this week, I’ve been having trouble setting up AWS in general. However I finally overcame this! My problem now is that when I access the instance it is extremely slow, everything from simple ls or cd commands to import theano in the jupyter notebook. Is there a reason for this?

Its also been mentioned that I would have to apply for a p2 instance? (running the t2 script currently) How do I go about getting the p2?

(oscar) #735

I have moved the post to:

(blair) #736

Hey everyone,
I’m just wondering how to efficiently transfer data to an instance. For example the dog-cat data needed for lesson one. Will I have to copy it to the instance every time I want to work with that data? And also will I get charged for transferring data to the instance?

(Sorin Panduru) #737

Hi @Ubi,
Are you sure you are loading the same ssh key you imported into aws ?
You could also check that you have write permissions (and path exists) to /home/ubi/.ssh/known_hosts . I see that it’s complaining that it can’t save a known host entry.

(Vijay Kumar) #738

I am trying to setup aws but facing below issue.
$ bash

An error occurred (AuthFailure) when calling the CreateVpc operation: AWS was not able to validate the provided access credentials

An error occurred (AuthFailure) when calling the CreateTags operation: AWS was not able to validate the provided access credentials
usage: aws [options] [ …] [parameters]
To see help text, you can run:

After googling i found that it is a NTP clock issue not synchronised with server clock.
Now I am trying to install NTP in Cygwin but I am unable to install
Can someone suggest me how to install NTP in Cygwin resolve this issue.
Did any one faced this problem.
please help… i am stuggling from last 2 days.

(Vamsi Uppala) #739

" /home/user/.ssh/aws-key-fast-ai.pem: No such file or directory You don’t have a ~/.ssh directory. To create one and set the correct permissions: "

This is the suggestion on AWS Install Wiki -
But I do have a .ssh directory and the aws-key-fast-ai.pem file in it. Inspite of it, I get the same error “No such file or directory”. How do I resolve this? Unable to find a thread that corresponds to this question. Thanks.


Thank you @sorinpanduru,
I didn’t find known_hosts in /home/ubi/.ssh/ . What could I do? Create an empty folder?

(Dan Gray) #741

Just in case anyone else hit this: Is due to window crlf vs unix lf. You can use a program called dos2unix to remove these extra \r that are in the script output that can be seen when using set -x for debug

For how to install dos2unix:



(Dan Gray) #742

Actually, I’m talking rubbish.

The best way to solve this particular issue is to create an environment variable in windows called SHELLOPTS with a value of igncr

Then relaunch cygwin (will probably be the same with win 10 bash) & that should be it.

More info: answer by DietmarTheMachine




Found a better solution for this issue:
Type this first: sudo apt-get update
Then you can install git successfully with this command: sudo apt-get install git

Hope this helpful ~

(Andrew) #744


I’m trying to setup access to the AWS setup I’ve already created on a second computer, but the ssh connection is the stumbling block. I don’t want to create another p2 or t2 instance, which is what the setup scripts do in addition to setting up the .pem file.

I tried running the file on it’s own, as it refers to the .pem file, but it gives and error saying it should be called by the p2 or t2 setup scripts.

My question is is there a way to just setup the ssh keys without creating another p2 or t2 instance on my aws account?




I’m getting mad about this. I’ve just started the course and I’ve just done 2 operations on cygwin:

pip install awscli

aws config

The second one rises my an error, despite the fact that the “not found” file is there, as you can see from my “dir” command. I’ve tried solution from the web (ie. stackoverflow) but still nothing.

Please, help me if you can. I’ve just started this corse and i’ts high demotivational :frowning:

(Chris) #746

I’ve been trying to start up the P2 server (no issues with the t2.micro) but noticed that the VPCs and instances created are not reflected in my dashboard / consoles. I’ve tried restarting again and had managed to shutdown the instance (t2.micro) using the CLI, though it was not reflected on my dashboard. However, I was unable to shutdown the VPCs by CLI.

More specifically, in the CLI, it shows 5 VPCs, but my dashboard / console only shows the default VPC. I believe that these are all associated with Oregon (us-west-2)

How can I get it to show on the console so I can delete it?

Here’s what I’ve tried:

  1. clicked through all the regions and there only seems to be the default vpcs.
  2. tried logging in from the admin account and the user account (used to generate the VPCs) - no diff
  3. I’m unable to shutdown the VPCs from the CLI due to a DependencyViolation - despite having removed the subnets, internet-gateways, security-groups, tags - must have missed out something.
  4. writing into AWS

I’ve looked at google, the AWS docs and wiki and the AWS and forums but can’t find the answer I’m looking for.

Would really appreciate help with figuring out why it’s not showing on the AWS console and deleting the VPCs since I’ve hit the limit and can no longer set up the P2 server.

(Erik) #749

I am stuck at this step: bash
I am using Mac OSx and getting the following error message:

True line 13: /Users/erik/.ssh/aws-key.pem: Permission denied

An error occurred (InvalidAMIID.NotFound) when calling the RunInstances operation: The image id ‘[ami-bc508adc]’ does not exist
Waiting for instance start…

It gets stuck here.

I am not sure what I am doing wrong. Any suggestions would be appreciated.

(Rajat Gupta) #750

Hi everyone,
I started with the course and completed the setup for aws but I was unable to ssh. So I deleted all the VPCs, Key Pairs(both on aws and local), Elastic IPs and instances. Now I started again with the setup and it was completed successfully.But I am still unable to ssh to my machine. Kindly help if you can.

I am continuously getting connection timed out although I am able to get ip and start/stop my instance from the terminal only.

rajatgupta@inspiron5520:~$ aws-ip
rajatgupta@inspiron5520:~$ aws-get-t2
rajatgupta@inspiron5520:~$ aws-start
STARTINGINSTANCES	i-031b712778d9f706e
rajatgupta@inspiron5520:~$ aws-ssh
ssh: connect to host port 22: Connection timed out
rajatgupta@inspiron5520:~$ aws-stop
STOPPINGINSTANCES	i-031b712778d9f706e
CURRENTSTATE	64	stopping

I guess this port 22 is not available. Am I right? If yes, please suggest any options to fix this. All valid suggestions are appreciated and thanks in advance.

(Rajat Gupta) #751

Hi Erik
I guess you have not checked if the AMI in the script is available in your region or not. Kindly check by launching an instance using the GUI console of AWS and replace it with the one you want to use in the script and then run setup.


(Erik) #752

Thanks Rajat,
Yes, there was an issue with AMI. It works now.