Quick Google Colab setup for Part 2 week 1 along with pascal VOC dataset


(Sharwon Pius) #22

I was able to run them by decreasing the data(no other option!), or decreasing the embedding size, batch size. How were you able to run the planet (multi-label classification) notebook ?

I ran almost 5-6 notebooks like that. Got help, for the rest.


(Sharwon Pius) #23

I submitted to kaggle competitions (dog-breeds, plant-seedling), just by using colab. But, you can’t get into the top using this.

The frequent disconnection was a pain (I think you’ll agree :sweat_smile: ) . I overcame this by running two colabs from different profiles (like, one in incognito mode). This saved me a lot of time.


(Aditya) #24

It isnt that way i guess
Because yesterday itself all my local variables were there even though i switched from Desktop to Laptop for the same nbs
(The cells might seem unexecuted but i directly did model.fit() and it ran )


(Arnav) #25

@ecdrid The machine you’re working on is irrelevant. You can probably use it from your mobile. It’s the VM which causes the issue.


(Aditya) #26

Here’s the nbs running on Colab- (had changed a bit in the directories to match the Jeremy’s as far as possible)

/data -> /data/pascal/ and added another mv line in the script written at the top of the thread by @sourabhd (works like a charm)

Let me know if there is any directory error.

You might receive cuda-runtime error on some cells but just re-run the cell and it disappears

The whole nbs ran successfully on my end.


#27

Thanks, this worked


(Aditya) #28

@sourabhd You can add two things to the script

  • change the data/ to data/pascal Everywhere
  • Add the mv command to move the Devkit(have a look at the nbs shared)(all this in an attempt to match Jeremy’s dir Structure)
  • change the Paths variable a bit below (named path,images etc)(mentioning might help)

It will make easier for others as we have aot of diversity among fellowmates here…


(Bigyan Karki) #29

Thanks buddy. That helps :slight_smile:


#30

Thankls @sourabhd. I made the following slight tweak for the installation of fast.ai library.

!pip install fastai==0.7.0