Port 22: Resource temporarily unavailable

after launching an instances on AWS ,when i tried to connect to connect it with with my local computer through ssh.i got this errorser

could anyone help me in figuring out what is wrong and how i should tackle it.so that i can start with jupyter notebook

thanks in advance

Hey Naveen … Are you using some shared LAN like in a University … ? It does happen that when LAN is used the ssh request bounces many times and then timeout occurs. However if you use wifi instead it gets connected instantly. So you can do one thing … Just use your mobile wifi for connecting to AWS and then continue using it with ur LAN . It then works smoothly.

1 Like

thanks vishal for your valuable point ,previously i was using a Lan cable straight from my router ,but now i tried with wifi option from the same router .the results are still same .i followed @ecdrid advice on checking once again the command i’m writing for ssh connection .the result i attaching with this post

Maybe because ur router connection is not efficient . That’s why I asked you to use ur mobile wifi. Actually it happened with me too . So I use mobile wifi for the connecting and after that continue to use LAN. So u can try it too using another wifi source .

1 Like

ok,i’ll give a try

after trying everything mi’m still stuck coulsd anybody help me ,please help me i’m struggling with this since afternoon
here what i have to offer to tell you all where i’m stuck
Aarambh@ADMIN-VAIO:~/.ssh$ ssh -i id_rsa ubuntu@ -L8888:localhost:8888
ssh: connect to host port 22: Resource temporarily unavailable
id_rsa is the name of my key pair,i used this command while i was in ssh directory

Maybe your AWS instance isn’t running, or its IP has changed?

Jeremy I tried creating new instance, even I tried generating new key pair , removing old one.but nothing worked

I didn’t actually suggest either of those actions :wink: This is not related to your key. It means either:

  • Your instance isn’t running, or
  • You’re using the wrong IP address, or
  • You have a firewall blocking you where you are connecting from

the first 2 points which you mentioned i check they are upto the mark ,3 point i need to check that my firewall is really blocking me to connect.

do a telnet check to make sure the port is accessable
"telnet 22"
you should see Connected message

if using AWS, I think you need to specify the pem (key) file option ?
ssh -i key.pem ubuntu@ -L8888:localhost:8888

The key is normally generated from AWS environment and it will ask you to download as file.

as you said i tried it showed me a connection failed message i.e.[Could not open connection to the host, on port 22: Connect failed]

ah then like you said could be firewall is blocking it.
But you could ssh into the machine ?

Disable your Anti virus …

And make sure you are using IPv4 …

I faced this last error message and don’t remember by whom I was guided that you are using wrong IP…

Not the private one…

but i’m using the default windows defender on windows 10.so,everytime when i want to connect AWS instance to my computer i should disable my window defender is that you are trying to say.

view the inbound rules…

where i can find inbound rules

Scroll where you have the IP,

Its under security gropus

Have you setup Security Group to allow port 22 access in the VPC ?
The rule should be something like this
15 AM

You need to define one and attach to your current instance.