Platform: Kaggle Kernels


(Allan Jackson) #21

1). Good to hear about your pets file.
2). I can’t help with the solution file. (I haven’t written one yet).
3). Thank You for telling me about the error you were having with my lesson 7 NB. Sadly it was running great 24 days ago. I was getting errors today with larger batch sizes in cell #2. It ran 7/8 of the way through with batch size of 12. Then error with “Runtime Error: The size of tensor a (45) must match the size of tensor b (15) at non-singleton dimension 0”. I won’t put anyone on access for this version till I get it working again.
4). Yes today Kaggle version for fastai = 1.0.39
Thanks again for the Heads-up!


(EPHRAIM AYEMERE) #22

I encountered this error while running the code below. any help?


(William Horton) #23

Make sure you have internet enabled in the Kernel


(Sanyam Bhutani) #24

Added a note in the top post


#25

Seems time limit was increased to 9 hours as per kaggle docs, didn’t test it yet…


#26

I think this is a result of insufficient shared memory, you can work around it my setting num_workers=0

https://www.kaggle.com/product-feedback/72606#latest-429470


(Gvido) #27

Hello,
i want to try out my own data set:
so i uploaded it as a .zip, and it shows in …input directory
my question now is, how do i specify it as a path and if i need to do any unzipping for the images?

Edit:
i tried to:

path = Path(’…/input/’)
path_img = Path(’…/input/celebs/celebs.zip’)

and when i run:
fnames = get_image_files(path_img)
fnames[:5]

i get an error: FileNotFoundError: [Errno 2] No such file or directory: '…/input/celebs/celebs.zip’

45bad7273fe32fb258d87ecf641122fa


(andreas) #28

Hi,
I am in lesson 1 and when I try to download the pet data I get this error message.

gaierror Traceback (most recent call last)
/opt/conda/lib/python3.6/site-packages/urllib3/connection.py in _new_conn(self)
140 conn = connection.create_connection(
–> 141 (self.host, self.port), self.timeout, **extra_kw)
142

/opt/conda/lib/python3.6/site-packages/urllib3/util/connection.py in create_connection(address, timeout, source_address, socket_options)
59
—> 60 for res in socket.getaddrinfo(host, port, family, socket.SOCK_STREAM):

Any ideas?

Solution: Although, I had enabled the internet connection, I needed to refresh my browser for it to work. All good now.


(Sanyam Bhutani) #29

Hi @andresa,
Can you double check if the ‘internet connection’ is enabled in the kernel?


(andreas) #30

Yes it is?


(andreas) #31

Hi Sanyam, after a refresh I have it working.
Thanks


(Sanyam Bhutani) #32

Kindly edit your question and add the solution there as well, Thanks.


(andreas) #33

Hi Sanyam,
All done.


#34

@wdhorton @miwojc

Can you please add me too? My kaggle user is dromosys

Thanks


(Sanyam Bhutani) #35

I’ve fixed the following kernels that had BusErrors and I’ve made some minor error fixes as well:

I think these errors were due to a version difference. Please let me know if you spot any other issues.
Thanks to @Ajaxon6255 for sharing many fixes. :slight_smile:


(andreas) #36

I am trying to run lesson 2 and the notebook keeps refreshing and losing all my work. How can I fix this?


(Sanyam Bhutani) #37

Not sure why that’s happening.
Do you have a fixed speed connection? It might be an outage at kaggle’s end.


(andreas) #38

does pressing commit save my work?


(andreas) #39

How do you save your work? My work is constantly lost by kaggle refreshing?


(Sanyam Bhutani) #40

@andresa Gotcha! So by default you’ll lose the data when you refresh, you need to commit to save the work.
Warning: For Lesson 2, since the number of images downloaded>500, the kernels will give an error because this is larger than kaggle’s limit.